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(eneral Safety Summary

Review the following safety precautions to avoid injury and prevent damage
to the measurement instrument or any products connected to it. To avoid
potential hazards, use the software and measurement instrument only as
specified.

While using this software, you may need to access other parts of the system.
Read the General Safety Summary and specification sections in other
equipment manuals for warnings, cautions, and ratings related to operating
the system with this software.

To avoid Fire and Personal Injury

Connect and Disconnect Properly. Connect the probe output to the
measurement instrument before connecting the probe to the circuit under test.
Disconnect the probe input and the probe ground from the circuit under test
before disconnecting the probe from the measurement instrument.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all
ratings and markings on the measurement instrument and other equipment
used with this software. Consult the individual product manuals for further
ratings information before making connections to the circuit under test.

Do Not Operate With Suspected Failures. If you suspect there is damage to
the measurement instrument or other equipment being used with this
software, have it inspected by qualified service personnel.

Terms in this Manual
These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could
result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could
result in damage to the measurement instrument or other property.

TDSVNM Timing and Protocol Decode Software v
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| nt r oducti on

About TDSVNM CAN and LIN Ti m ng and Protocol
Decode Sof tware

The TDSVNM CAN and LIN Timing and Protocol Decode Software is a low
speed serial bus test software program for CAN and LIN buses that run on
Tektronix oscilloscopes. The software helps to decode CAN and LIN
protocol messages simultaneously, set trigger conditions based on the CAN
bus message, capture data for specific conditions of the in-vehicle network,
decode and display the captured CAN and LIN messages, and analyze the
displayed frames. TDSVNM offers timing analysis tests that help
characterize CAN node performance.

The TDSVNM CAN and LIN Timing and Protocol Decode Software offers
the following:

®  Protocol Decoding

®  CAN bus

®  LIN bus

®  CAN & LIN buses
®  CAN Timing Tests

®  Eye Diagram

®  Oscillator Tolerance

®  Data Rate

®  Bus Traffic

" Wakeup Time

®  Propagation Delay

TDSVNM Timing and Protocol Decode Software 1
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Using Online Help

The TDSVNM CAN and LIN Timing and Protocol Decode Software online
help serves as a reference for using the TDSVNM CAN and LIN Timing and
Protocol Decode Software.

Contents: The Contents tab displays books and pages that represent the
categories of information in the online Help system.

Index: The Index tab displays a multi-level list of keywords and keyword
phrases. These terms are associated with topics in the Help system and direct
you to specific topics.

Search: The Search tab enables you to search for keywords in the Help
system and to locate topics containing those words. When the search is
completed, a list of topics is displayed so you can select a specific topic to
view.

Back and Forward: The Back and Forward buttons allow you to browse
through topics.

To print a topic: Select the Print button from the Help Topics menu bar.

Application Description

Applications

Some typical applications while developing, integrating, operating, and
updating the CAN and LIN network are as follows:

Easy System Integration: Adding new features to existing in-vehicle
networks often results in adding new CAN nodes (devices). While integrating
a new CAN node, there is a need to ensure that the CAN node is
synchronized for seamless network operation. The oscillator tolerance and
propagation delay measurements help to locate any network synchronization
problems.

CAN/LIN network management: An in-vehicle network in a car enables
communication between auto body parts such as doors, seats, dashboard,
airbag, and engine parts such as the engine, steering, and gear box. A tool that
helps to monitor the communications between different segments of the
vehicle network is needed.

Protocol Decoding: The performance of an existing in-vehicle network is
improved by enhancing the software in upper layers of the OSI model. This
involves updating the existing vehicle firmware and testing its performance.

Monitor multiple protocols: An in-vehicle network is heterogeneous. Based
on the cost and performance of a node, automotive manufacturers use
different networks and integrate them using gateways.

2 TDSVNM Timing and Protocol Decode Software
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Feat ur es

TDSVNM CAN and LIN Timing and Protocol Decode Software offers the
following features and benefits:

®  Oscillator Tolerance and Propagation Delay measurements help in
addressing network synchronization issues

®  Simultaneous protocol decoding of CAN and LIN messages helps in
ensuring communication accuracy and acceptable latency between the
two segments of the network

" Ability to link decoded and time-stamped CAN messages to its timing
waveform to clearly visualize bus functions

®  Integrated search functions help to efficiently debug network problems
in the data link layer

®  CAN Eye diagram analysis quickly locates noise in the CAN message
caused by jitter, amplitude aberration, spikes and glitches

®  Bus Traffic measurement helps in optimizing network performance and
bus utilization for different CAN message frames

®  Support for various CAN configurations: CAN single wire, CAN Dual
wire, CAN fault tolerant makes TDSVNM useful for a wide range of
CAN signaling types

B Speedy network debug by setting trigger conditions based on CAN
message content such as ID, DATA and DLC

B Setting trigger conditions to detect overload, passive error, active error
and remote frames helps to quickly identify CAN network
communication errors

®  Powerful conditional triggers such as if-then-else enable users to
monitor the CAN network and efficiently capture intermittent or
occasional events

B Characterize long duration network timing performance by triggering on
the nth occurrence of a specific CAN message or triggering only after a
user specified time has elapsed

" Ability to generate ACK Bit removes the need for a receiving CAN node
while testing a single CAN node

®  Capability to use the DPO-CAN Bus Trigger feature
Easy System Integration

CAN and LIN nodes are connected to form an in-vehicle network. CAN is a
serial, asynchronous, and multi-master communication network. The data is
transmitted from one CAN node to another CAN node with overhead and
payload. The receiving node samples the incoming data using the internal

TDSVNM Timing and Protocol Decode Software 3
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clock. The oscillator, which resides in each CAN node, generates the internal
clock. The sample point is programmed at an appropriate bit interval such
that data from a distant node is interpreted accurately. The sample point can
be programmed anywhere between 20% and 90% of the bit time. The sample
point position depends on the following:

B Oscillator tolerance of the receiving CAN node
®  Propagation delay from the transmitting node to the receiving node

If the sample point is set at 50% of the bit time, you may be limited to using
short cables for the network. If the sample point is set at 80% of the bit time,
you may be able to use longer cables. This requires a very high tolerance
oscillator, which generates the sampling clock. A low tolerance oscillator
may cause sampling beyond the bit time and wrong interpretation of the data
by the CAN node.

It is apparent that a low tolerance oscillator is not compatible with long cable
length. Oscillator tolerance also varies with the operating temperature and
age of the CAN network.

New nodes are added to the existing network to add more features to the
vehicle. During system integration, you need a tool that allows you to
synchronize the new CAN node by setting an appropriate sample point
location in the bit time, based on the oscillator tolerance of the CAN nodes
and propagation delay of the network.

TDSVNM is a tool that helps in characterizing the oscillator tolerance and
propagation delay of the CAN network. TDSVNM helps to easily integrate
an in-vehicle network and add new CAN nodes to the existing network.

Net wor k Managenent

CAN and LIN network enables the communication between doors, seats,
dashboard, airbag, and engine parts. The communication needs to be efficient
and timely between the CAN and LIN nodes. To measure the effectiveness of
the communication, you need to capture the physical layer activity using an
oscilloscope. This data will be in the YT format, which is difficult to
interpret. Analyzing a YT waveform is time consuming and prone to errors.
You might want to view the YT data in hexadecimal, binary, or decimal
format.

Each CAN node expects to communicate in a timely manner. This
requirement becomes critical for the safety bus, since it controls the airbag
and ABS. To characterize this part of the communication, you need a tool
that allows you to measure the time difference between the communication of
the node that provides input and the nodes that respond to the input.

An in-vehicle network manages combustion, emission, safety and comfort
needs of the vehicle by continuous communication. For reliable operation of
the CAN and LIN, network traffic needs to be monitored for a long time.

TDSVNM Timing and Protocol Decode Software
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Moni toring Multiple Protocols

An in-vehicle network is heterogeneous. Based on performance requirements
and the cost of a node, automotive manufacturers use different networks and
integrate those using gateways. Two dominant networks are CAN and LIN.

In a CAN network, different data speeds are used based on the application of
that segment of the network. In many cases there could be communication
across the two-segment networks through a gateway. You need to ensure that
communication across the gateway is accurate and timely. To characterize
this, you need tools that would provide simultaneous decoding of the data for
each segment of the network.

A typical example for a CAN-LIN network is as shown in Figure 1-1:

AN CAN
:r Motor HID ‘:
CAN | ECUCANto | un ¢ | ECYTor AFS —@M :
LIM : HID Gear Drive !
| O cerrnr s e IR LR ; Ballast :
CAN %
Motar HID
ECU for AFS (Eij-g}g:%
 — HID Gear Drive
.= -.L.:_'&'_r\{ __________________________ Ballast

Figure 1-1: Exanple of a CAN- LIN network

In this application, design engineers and system integration engineers would
need to monitor the LIN and CAN protocol across the gateway. In the
picture, the gateway is an ECU that converts LIN to CAN protocol and vice
versa. Engineers need to monitor the delays in the two-way communication
between the CAN and LIN network. This is because each of the segments of
the network operates at different speeds. The delay between the CAN and
LIN gateway would affect the movement of the gears that control the
headlight position.

Pr ot ocol Decodi ng

The performance of an automotive, medical electronics or industrial
automation network is improved by enhancing the software in upper layers of
the OSI model. This involves updating the existing vehicle firmware and
testing its performance. During firmware update, you need to monitor the
physical layer activity of the CAN in hexadecimal, binary or decimal format,
and then optimize the performance of the network.

TDSVNM Timing and Protocol Decode Software 5
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About the ATM 1 Autonotive Trigger Mdule

The ATM-1 Automotive Trigger Module monitors the CAN bus protocol and
provides an output signal to trigger a Tektronix oscilloscope when a user-
specified bus condition occurs.

The ATM-1 automotive trigger module is manufactured by Crescent Heart
Software (CHS). Refer to www.c-h-s.com for contact information.

The ATM-1 monitors the behavior of the bus to which it is connected, and
can also send signals to the bus in specific situations (for example, to
optionally signal an acknowledge on the CAN bus).

The ATM-1 functions as an addition to an oscilloscope, enabling the
oscilloscope to be triggered when a complex signaling situation occurs on the
bus. The ATM-1 can track and produce a trigger signal as a result of
signaling conditions that are too complex for the oscilloscope to trigger on.
Such complex signaling conditions occur as a result of the multiple levels of
signaling protocol implemented on the CAN bus.

The ATM-1 is packaged in an aluminum metal case with front and rear-panel
signal input and output connectors.

Appl i cation Environnent

An oscilloscope uses standard probes to monitor the electrical activity of the
bus signal(s). For single wire buses, the signal voltage is determined relative
to the system ground. For dual wire buses, which use differential signaling,
the differential voltage is determined using either a differential probe or two
conventional (non differential) probes with the algebraic voltage difference
mathematically computed by the oscilloscope.

The ATM-1 also connects to the bus signal(s), allowing the module to
monitor the logical behavior of the bus.

Tri gger Modul e Connecti ons

A D-SUB 25-pin male connector on the front panel of the ATM-1 accepts the
bus signals to be monitored. Connecting the bus signals to the ATM-1
requires wiring the 25-pin female mating connector provided with the unit, or
using the optional companion cable assembly.

The ATM-1 produces a TTL-compatible 50-Q back-terminated trigger output
through a BNC connector on the rear panel of the unit; use the standard 50-Q
BNC cable provided with the ATM-1 to connect the ATM-1 trigger output to
a trigger input on the oscilloscope. The trigger state machine of the ATM-1
creates an output signal on the trigger output according to user-specified
trigger events.

TDSVNM Timing and Protocol Decode Software
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The ATM-1 can be connected to the oscilloscope using the USB port on the
rear panel of the unit. Through this connection, the application software
running on the oscilloscope can set up trigger conditions, control, and
monitor the trigger module.

The bicolor (yellow/green) LED on the ATM-1 front panel indicates the
presence of power, the status of the USB connection, and certain error
conditions.

Buses and Bus Connecti ons

The current version of the ATM-1 firmware supports following versions of
CAN bus:

®  CANH, CANL: High- or medium-speed CAN bus differential signals,
In/Out

®  FTCANH, FTCANL: Fault-tolerant low-speed CAN bus differential
signals, In/Out

B SWCAN: Single-wire CAN bus signal, In/Out

TDSVNM Timing and Protocol Decode Software 7
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Printing fromthe Online Help

Conventi ons

While using the online help, you can print topics and information from the
HTML Help viewer.

To print a single topic:

1. Find the topic in the Contents pane.

2. Click Print.

3.  Click Print the selected topic and click OK.

To print all topics in a selected TOC book:

4. Find the TOC book in the Contents pane.

5.  Click Print.

6. Click Print the selected heading and all subtopics and click OK.

Some online help topics have color in the examples of the displayed
application. If you want to print this type of topic on a monochrome printer,
some colors may not print. To avoid this problem, print the topic from the
PDF file that corresponds to the online help. You can find this file in the
Documents directory on the Optional Applications Software on Windows-
Based Oscilloscopes CD-ROM. The application menus in the PDF file are
gray scale and all the information can be printed.

Online help uses the following conventions:

®  When steps require a sequence of selections using the application
interface, the ">" delimiter marks each transition between a menu and an
option. For example, File > Minimize.

®  DUT refers to the transmitter of the signal to be tested.

Updates fromthe Wb Site

You can find information about this and other applications at the Tektronix
Inc. Web site, www.tektronix.com. Check this site for firmware updates and
other information about our application.

TDSVNM Timing and Protocol Decode Software
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Feedback

Tektronix values your feedback on our products. To help us serve you better,
please send us your suggestions, ideas, or comments on the application.

Direct your feedback using email to techsupport@tektronix.com or tdsvnm-
feedback@tek.com. You can also send feedback by FAX to (503) 627-5695.
Please include the following information and be as specific as possible.

General information:

®  Instrument model number and hardware options if any, with serial
number

®  Probes used

®  Your name, company, mailing address, phone number, FAX number,
email address

®  Please indicate if you would like to be contacted by Tektronix about
your suggestion or comments

Application specific information:
®  Software version number

®  Description of the problem such that technical support can duplicate the
problem

®  The setup file of the oscilloscope and the application is also required to
identify the problem

" [fpossible, save the waveform on which you are performing the
measurement as a .wfm file

Note: To find the Software version number, click Help > About in the
application.

Once you have gathered this information, you can contact technical support
by fax or through email. If using email, be sure to enter "TDSVNM Software
Problem" in the subject line, and attach the .wfm files.

You can then attach the file to your email (depending on the capabilities of
your email editor).

TDSVNM Timing and Protocol Decode Software 9
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Getting Started

Conpatibility

For information on oscilloscope Compatibility, refer to the Optional
Applications Software on Windows-Based Oscilloscopes Installation Manual,
Tektronix part number 071-1888-00. The manual is also available as a PDF
file.

Reconmended Accessori es

The following probes are supported by the application:

= P5205
= P5200
®  P6246
" P6247
" P6248
= ADA400A

®  TCA-1MEG, probe adapter for use with supported oscilloscopes

®  TPA-BNC, TEKPROBE™ BNC adapter for use with supported
oscilloscopes

Starting the Application

Depending on the type of oscilloscope that you have, you can start the
software in the following way:

1. To start the application, do one of the following:

e Select File > Run Application > in the oscilloscope menu bar. Then
select CAN and LIN Timing and Protocol Decode Software

e Select App > CAN and LIN Timing and Protocol Decode Software

e Select Analyze > CAN and LIN Timing and Protocol Decode
Software

2. A splash screen indicates that the software loading is in progress.

3. The oscilloscope display resizes to fit in the upper part of the screen.
The lower part of the oscilloscope screen displays the TDSVNM CAN
and LIN Timing and Protocol Decode Software.

TDSVNM Timing and Protocol Decode Software 11



Getting Started

4. The software is automatically set to its default settings.

5. Ifyou gain access to the oscilloscope functions, then the oscilloscope
display appears full screen and the TDSVNM CAN and LIN Timing and
Protocol Decode Software recedes to the background.

6. To return to the TDSVNM CAN and LIN Timing and Protocol Decode
Software, do one of the following:

e Select App on the top right of the oscilloscope display
e Select App > Restore Application

e Select Analyze > Restore Application

Requi renments and Restrictions

Requirements
DPO-CAN Bus trigger is required:
®  To define Elementary Trigger

B To carry out the Oscillator Tolerance, Eye Diagram, and Data Rate
tests

The ATM-1 Automotive Trigger Module is required:

" To specify trigger conditions and perform elementary, logical or
advanced triggering during protocol decoding

®  To carry out the Oscillator Tolerance, Eye Diagram, and Data Rate
tests

The ATM-1 Automotive Trigger Module can be ordered from Crescent Heart
Software (www.c-h-s.com). Contact a Tektronix representative for more
details.

Restrictions

It is recommended that you do not connect more than one ATM-1 module to
an oscilloscope.

Maxi m zing and M nim zing the Application

12

B The software appears even when you minimize the oscilloscope display.

®  To minimize the software, click File > Minimize. The TDSVNM CAN
and LIN Timing and Protocol Decode Software window minimizes to
the Windows taskbar. The upper part of the screen has the oscilloscope
display and the lower part of the screen has the desktop.

®  To restore the minimized window to its previous size, click its taskbar
button.
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®  To hide the window, click E on the top-right of the software

window.

Returning to the Application

When you gain access to the oscilloscope functions, the oscilloscope fills the
display. You can access the oscilloscope functions in the following ways:

®  Choose either the menu bar or the toolbar mode on the oscilloscope, and
then gain access to the menus.

®  Click App > Restore Application or click APP on the top right of the
oscilloscope display to return to the software.

Exiting the Application
To exit the software:

1. On the menu bar, click File > Exit or click 5.8
2. The Exit dialog box appears.

3. Click either Yes, No, or Cancel. Yes is selected by default. When the
software runs, it automatically changes some oscilloscope settings.
When you quit the software, you can choose whether to retain these
settings or restore the previous settings.

Application Directories and Usage
The TDSVNM CAN and LIN Timing and Protocol Decode Software uses

directories to save and recall setup files and uses file name extensions to
identify the file type. Table 2-1 lists the default directory names.

Table 2-1: Directory names and their use

Default directory names* Directory use
C:\TekApplications\TDSVNM TDSVNM application home location
\Images Plot files

\Reports Results of protocol decoding
\Setup Setup files for TDSVNM

\Temp Temporary files

*All subdirectories are located in the C:\TekApplications\TDSVNM directory.
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Pr ot ocol

Decodi ng and Ti m ng Anal ysis Tests

The TDSVNM CAN and LIN Timing and Protocol Decode Software offers

the tests as shown in Table 3-1:

Table 3-1: Descriptions of protocols and tests

Protocol or Test

Description

CAN bus (Controller Area
Network)

Converts the waveform acquired by the oscilloscope from the Controller Area Network
into a bit stream and decodes it to display CAN protocol messages in the protocol
analysis window.

The application supports CAN Dual Wire, CAN Single Wire and CAN Fault Tolerant
buses.

LIN Bus (Local Interconnect
Network)

Converts the waveform acquired on the Local Interconnect Network into a bit stream
and decodes it to display LIN protocol messages in the protocol analysis window.

CAN and LIN

Decodes and displays the waveform acquired simultaneously on CAN and LIN buses.

Eye Diagram

Represents the overlaying of the individual NRZ bits of a CAN message. This allows
you to find electrical noise in the CAN message such as amplitude aberration, jitter,
spikes and glitches. The ability to view Eye diagram with Ack and without Ack bit allows
you to realize the impact of propagation delay on the bit time and adjust the sample
point accordingly.

Oscillator Tolerance

Measures the deviation of the oscillator deduced from the transmitted data. This
enables you to program the segments and to operate the node synchronously with
other nodes. Oscillator tolerance is measured in percentage.

Data Rate

Extracts the data rate of the selected node based on the ID from the acquired CAN
frame signal. Data rate is measured in Kbps.

Bus Traffic

Determines the load of the CAN message on the CAN bus network expressed as
percentage of bus occupancy. Determines the details of the message that occupies the
bus of the selected node. It also gives the number of CAN messages and frame types
on the network. Bus traffic is measured in percentage.

Wakeup Time

Measures the time difference between time of the ignition signal to the first CAN
message during network start up. Wakeup time is measured in seconds.

Propagation Delay

Measures the time taken for a message to travel from one end of the network to the
other end. This is measured for the signal transition on the start frame of the message.
Propagation delay is measured in seconds.

TDSVNM Timing and Protocol Decode Software
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TDSVNM Appl i cation View

Figure 3-1 shows the default application view and its areas.

Hide Exit
Menu bar button  hutton

File Tests Results Utilities Help TDSVNM m| x|

CAH and LIH Protocol Decoding CAH Timing Anahlysis Tests

Oscillator Evye Bus
Tolerance Liagram Traffic

| [ata iakeup Frapaga-
T LIM
g -
Setup
CAN

CAM | Bus1: Chi; CAN-DW-HL; 10kbps; BusZ: Mone; Nnr; 10kbps | Trig On: Data FramT Rear:h,r
Telect | o _ Contral panel
S Rang Pratocal Status bar Timing analysis
decoding area tests area

Figure 3-1: Application view and its areas

Menus

The menu bar of TDSVNM software consists of the following menus (as
shown in Figure 3-2):

File Testz REesults LUtilities Help
Figure 3-2: Application Menu

File Menu

File Tests Results LUtilities Help

Recall Default

Recall...
Save...

Eecall Becent »

Preferences

Minimize
Exit

Figure 3-3: File Menu
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Table 3-2: File Menu selections and their descriptions

Menu selection Description

Recall Default Click File > Recall Default to recall the default settings for both the software and the
oscilloscope.

Recall Click File > Recall to recall the previously saved settings for the software from an .ini
file.

Save Click File > Save to save the software settings to an .ini file.

Recall Recent Click File > Recall Recent to select among the recently saved and recalled setups.

Preferences Click File > Preferences to set preferences.

Minimize Click File > Minimize to minimize the software window.

Exit Click File > Exit to quit the software.

Tests Menu

File iIests Results  Ulilities Help
Select
Configure
Trigger Setup
Connect

Figure 3-4: Tests Menu

Tabl e 3-3: Tests Menu sel ections and their descriptions

Menu selection Description

Select Click Tests > Select to display or modify the protocol or test selection.

Configure Click Tests > Configure to display or modify the configuration parameters for the
selected protocol or test.

Trigger Setup Click Tests > Trigger Setup to display or modify the trigger parameters and trigger

type for the selected protocol or timing test.

Connect Click Tests > Connect to display the connection instructions for the selected
protocol or test.

Results Menu
File Testz | BEesults Litilities Help
Details
Figure 3-5: Results Menu

Click Results > Details to display the detailed results of the last test that was
conducted.
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Utilities Menu

File Tests Results | Wilities Help

ATH-1 License Installation
Figure 3-6: Uilities Menu

Click Utilities > ATM-1 License Installation to install or upgrade ATM-1
automotive trigger module license key information.

Hel p Menu

File Tests Eesults gtilitieslﬂelp

Help Topics
About TDSWRM
Ahout ATh-1

Figure 3-7: Help Menu

Tabl e 3-4: Help Menu selection and their descriptions

Menu selection Description

Help Topics Click Help > Help Topics to display the help file for the TDSVNM CAN and LIN
Timing and Protocol Decode Software.

About TDSVNM Click Help > About TDSVNM to display a dialog box with information about the
current TDSVNM CAN and LIN Timing and Protocol Decode Software.

About ATM-1 Click Help > About ATM-1 to display a dialog box with information about the current
ATM-1 automotive trigger module.

Sel ecti on Panel

The selection panel appears at the far left of every screen. It allows you to
navigate through the TDSVNM application.

Select

Canfigure

Trigger
Setup |

Connect

Figure 3-8: Sel ect panel
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Tabl e 3-5: Sel ect

Table 3-5 shows the buttons and their descriptions:

panel buttons and their descriptions

Button Description

Select Click Select to display the protocols and timing tests to select from.

Configure Click Configure to display the configuration parameters for the selected protocol or
timing test.

Trigger Setup Click Trigger Setup to display the trigger parameters and trigger type for the selected
protocol or timing test.

Connect Click Connect to display the connection instructions for the selected protocol or timing

test.

Control Panel

Results

Clear

|

Figure 3-9: Control

Tabl e 3-6: Control

After you select and configure a protocol or test, you can either set up the
trigger conditions or make equipment connections for the selected protocol or
test.

The control panel appears at the far right of every screen. It controls all of the
application’s operations.

panel

Table 3-6 shows the buttons and their descriptions:

panel buttons and their descriptions

Button Description

Run Executes the protocol decoding or test selected. The Run button changes to Stop when the
test is running. You can stop the test by clicking the Stop button.

Results Displays the respective Result details panel for the protocol or the test that is configured.

Clear Clears the results displayed on the results screen.

Sequence Mode

Single Run Same as the “Single” button on the oscilloscope front panel.

Free Run Runs continuously until you press Stop.

No Acq Conducts the test without acquiring the waveform.
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Note: When Ref sources are selected in configuration panel, only the No Acq
sequencer mode is available.

St at us Bar
The status bar at the bottom of the application screen dynamically updates
according to your selection. The status bar shows the selected Protocol or
Test, Configuration parameters, Hints, and Sequence state.

CAM | Busi: Chi; CAN-DW-HL; 10kbps; BusZ: Hone; Mone; 10kbps | Trig On: Cata Frame Ready

Fi gure 3-10: Status bar

Setting Preferences

File > Preferences

Figure 3-11 shows the preferences that you can set.

Preferences E2

Math Destination (for Single-Ended Probes)

Bus1 Source

Bus2 Source

CAH Hode Sensor Source

Reference Level
Bus1 Source Bus2? Source CAH Hode Source

Units Units Slope

Uinit=
S0%
Hy=steresis : Hy=steresis :
Hysteresis .

. Do Autoset Every Time

Cancel

Figure 3-11: Setting preferences
Math Destination is applicable only when:

®  The probe type is single-ended
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®  The bus type is CAN-DW-HL, CAN-DW-LH, CAN-Fault-T-HL, or
CAN-Fault-T-LH

However, Reference Level is used for all bus sources.

Table 3-7 shows the preferences and their descriptions.

Table 3-7: Preferences options and their descriptions

Options

Description

Math Destination

Bus1 Source

Select the Bus1 source from Math1, Math2, Math3, Math4.

Bus2 Source

Select the Bus2 source from Math1, Math2, Math3, Math4.

CAN Node Sensor Source

Select the CAN Node Sensor source from Math1, Math2, Math3, Math4.

Reference Level for Bus1 Source, Bus2 Source, and CAN Node Source

Slope* Set the slope to Rise or Fall.

Units Select the units from Percentage and Absolute.

Mid Set the Mid range value in the units specified.
Hysteresis Set the Hysteresis range value in the units specified.

Do Autoset Every Time

Select this option to perform autoset every time you click Run whether any parameters in
the Config panel have changed or not.

When this selection is cleared, autoset is performed only when the Bus Type or Bus
Source changes in the Config panel.

* Slope is applicable only for CAN Node Sensor Source.

Note: For Timing Analysis tests, Bus2 preferences are disabled because the
tests are performed for the bus that is configured.

Virtual Keyboard

Virtual Keyboard - Numeric
1. Click any number box to display the icon for the numeric keyboard.

2.  Click the icon to display the numeric keyboard.
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Figure 3-12 shows the numeric keyboard.

Bit Rate

Kl Bl KX

+i-
o]

Fi gure 3-12: Virtual keyboard - nuneric

3. Click the number keys to enter the desired value.
4. Select a unit of measure.

5. Click Enter to confirm your entry. Selections are not effective until you
click Enter.

Virtual Keyboard - Binary
1. In the Trigger Settings window, set Format to Binary.

2. Click the number box next to the ID, DLC, or Data fields to display the
icon for the binary keyboard.

Figure 3-13 shows the binary keyboard.

Figure 3-13: Virtual keyboard - binary
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3. Click the number keys (X, 1, 0) to enter the desired value. X represents a
'Don't Care' value.

Note: If a value has already been entered, click Clear to clear the entry
before entering a new value.

4. Click Apply to confirm your entry. Selections are not effective until you
click Apply.

Virtual Keyboard - Hexadecimal
1. In the Trigger Settings window, set Format to Hex.

2.  Click the number box next to the ID, DLC, or Data fields to display the
icon for the hexadecimal keyboard.

Figure 3-14 shows the hexadecimal keyboard.

Figure 3-14: Virtual keyboard - hexadeci nal

3. Click the number keys (0 through 9, A through F, and X) to enter the
desired value. X represents a 'Don't Care' value.

Note: If a value has already been entered, click Clear to clear the entry
before entering a new value.

4. Click Apply to confirm your entry. Selections are not effective until you
click Apply.
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Sel ect
Protocol and Tining Analysis Tests
Figure 4-1 shows the protocols and timing analysis tests.
File Tests Results Utilities Help TDSVHM m| x|

Salact CAH and LIH Protocol Decoding CAH Timing Analysis Tests
. . O=cillatar Eve Bu=
| CAM ; :
Canfigure Tolerance Diagram Traffic

— 1 [ata Wakeup Fropaga-
[ R ate Time tion Dela
Setup |

Connect

CAM | Busl: Chil; CAN-DW-HL; 10kbps; Bus2: Nane; Mone; 10kbps | Trig On: Crata Frame Ready

Figure 4-1: Selecting a protocol or test

Table 4-1 shows how to select the protocol to decode:

Table 4-1: Selecting a protocol

Test Type How to select

Protocol Click Tests > Select from the menu to view the tests.

CAN In the CAN and LIN Protocol Decoding area, click CAN.

LIN In the CAN and LIN Protocol Decoding area, click LIN.

CAN & LIN In the CAN and LIN Protocol Decoding area, click CAN & LIN to select both the
protocols to decode.
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Table 4-2 shows how to select the timing analysis tests:

Table 4-2: Selecting a tinming test

Test Type How to select

Timing Analysis Tests Click Tests > Select from the menu to view the tests.
Oscillator Tolerance In the Timing Analysis Tests area, click Oscillator Tolerance.
Eye Diagram In the Timing Analysis Tests area, click Eye Diagram.

Bus Traffic In the Timing Analysis Tests area, click Bus Traffic.

Data Rate In the Timing Analysis Tests area, click Data Rate.

Wakeup Time In the Timing Analysis Tests area, click Wakeup Time.
Propagation Delay In the Timing Analysis Tests area, click Propagation Delay.

Configure

Confi gure Protocol

On the menu bar, click Tests > Configure to configure the parameters for the
selected protocol. Figure 4-2 shows the configuration parameters for
protocols.

File Tests Results Utilities Help TDSVNM |y x|

Trigger
Using

Trigger
Setup

Configure Source
Ch

Source

Connect Nane

Configure

CAH Hode Sensor
DFO-CAN ™ Probe Type Crifferential Source

Bus 1 (Trigger Source) Mone W
Bus Type Bit Rate m
o [

T CAN-DW-HL 10kbp=

Bus Type Bit Rate

w Hone 10kbps=

Data Run Mode

Single W

CAM | Busi: Chi; CAN-DW-HL; 10kbps; BusZ: None; Mone; 10kbps | Trig On: Data Frame Ready

Figure 4-2: Configuring a protocol or test
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In the configure pane, you will see the factory default configuration for the
test you selected. For most tests, you can use the factory default
configuration. However, you can change the values by using the virtual
keyboard or the general purpose knob on the oscilloscope front panel. Using
the File menu, you can also restore the factory defaults or save and recall
your own configuration settings.
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The following table shows the parameters that you can configure for protocol

decoding.
CAM MNode
g Sensor
- = o
2| & 2 o A
HETEE: £ |z : ; : £
28| o 2 w D w S = 3 C
2o | cwm g 30 =] =] = =] fa c
oo | =23 o o ow o w ] wn - |
CAM | DPO- Differential | Bus 1| CAMN-DW-LH, | Chi, Chz, 10 Kbps—1 Mbps | Chi, Chz, ¥ | Tirming,
cans (Trigger | CAM-DW-HL, | Ch3, Chd, Ch3, Chd, Data**
ATM-1 Source) | CAMN-SWE, Refl, Refz, 10-100 kbps Refl, Refz,
Standard fBus 2| CAN-Fault-T- | Ref3, Refd, 10-125 Khbps Refi, Refd,
Single- HL, {Mone) Mone
ended CAMN-Fault-T-
LH, (Mone) | Chil-ChZ, Ch3- chil-chz,
Cha, Ch1-Ch3, Ch3-Chd,
Chz-ch3, chil-chs,
Refl, Refz, Chz-ch3,
Refd, Refd, Refl, Refz,
{Mone) Ref3, Refd,
Mone
LIN Differential, | Bus 1 LIM, {Mone) Chi, Chz, 1 Kbps—20 Kbps | MNA Ma& | Timing,
Single- (Trigger Cha, Cha, Drata**
ended Source) Refl, Refz,
fBus 2 Refd, Refd,
(Mone)
CAM [ DPO- Differential Bus 1 CAMN-DW-LH, | Chi, Chz, 10 Kbps-1 Mbps | Chl, Chz, ¥ Timing,
1 cans (Trigger | CAM-DW-HL, | Ch3, Chd, Ch3, Chd, Data**
LIN | aTm-1 Source) | CAM-SW*, Refl, Refz, 10-100 Kbps Refl, Refz,
Ztandard CAMN-Fault-T- | Ref3, Refd, 10-125 Khps Ref3, Refd,
Single- HL, {Mone) Mone
ended CAMN-Fault-T-
LH Ch1-chz, Ch3- Chl-chz,
Chd, chi-Ch3, Ch3-Chd,
Chz-ch3, Chil-Ch3,
Refl, Refz, Chz-Ch3,
Ref3, Refd, Refl, Refz,
{Mone) Ref3, Refd,
Mone
Differential, | Bus 2 LIM Chi, Chz, 1- 20 kbps M " Timing,
=Zingle- Ch3, Chd, Data**
ended Refl, Refz,
Ref3, Refd,
{Mone)

* Faor the CAN-3W Bus Tyvpe and Single-ended Probe Type, the source channel selection is always Chl, Chz, Ch3, Chd, Refl,

RefZ, Ref3, Refd

** For Ref sources, Timing/Cata Analysis is not available,

& When Trigger Using is set to DPO-CAMN, the application supports the standard data rates,

Note: When Ref sources are selected in configuration panel, only the No Acq
sequencer mode is available.

For two-channel oscilloscopes, source selections Ref3, Ref4, Ch1-Ch3, and
Ch1-Ch4 are not available.

In the Configure Panel, an option input Trigger Using is available to use the
internal trigger feature of the instrument in the application. Trigger Using has
three selections: DPO-CAN, ATM-1, and Standard.
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®  DPO-CAN: This selection is available only on a DPO-series
oscilloscope when CB:CAN Bus Trigger option is installed. When
Trigger Using is set to DPO-CAN, the application supports the
following standard date rates:

10 Kbps, 20 Kbps, 33.3 Kbps, 50 Kbps, 62.5 Kbps, 83.3 Kbps, 100
Kbps, 125 Kbps, 250 Kbps, 500 Kbps, 800 Kbps, and 1 Mbps.

®  ATM-1: This selection is available to use ATM-1 trigger module

®  Standard: This selection is available only for CAN and LIN protocol
decoding and not applicable to CAN-Timing Analysis Tests. In this
selection, you need to configure the required trigger settings in the
Trigger panel of the oscilloscope to standard triggers such as Edge,
Width, Glitch.

Note: Trigger Using selection is not applicable to Wakeup time and
Propagation delay measurements.

After you select and configure a protocol or test, you can either set up the
trigger conditions or make equipment connections for the selected protocol or
test.

Confi gure CAN Protocol

Figure 4-3 shows the configuration parameters for the CAN protocol.

File Tests Results Utiliies Help TDSVNM || x|

Configure

Trigger — — CAH Hode Sensor
Using DFO-CAN ™ Probe Type Drifferantial Source

-

Bus 1 ({Trigger Source) MNone
Configure Source Bus Type Bit Rate m

Chi - CAN-DW-HL ™ 10kbps

Trigger
y - Clear
Setup Bus 2 Anahysis -

Source Bus Type Bit Rate P Run Mode

Connect Hone - Hone 10kbps Single ™

CAMN | Busi: Chi; CAN-DW-HL; 10kbps; BusZ: Mone; Hone; 10kbps | Trig On: Data Frame Ready

Fi gure 4-3: Configuring a CAN protocol
Follow these steps to configure the CAN bus.

1.  On the menu bar, click Tests > Configure to configure the parameters for
the selected protocol.
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Tabl e 4-3: CAN protocol

Table 4-3 shows the parameters that you can configure for CAN
protocol decoding. You can decode two CAN buses simultaneously.

configuration paraneters

Parameter Description

Trigger Using

DPO-CAN Sets the trigger to use to DPO-CAN
ATM-1 Sets the trigger to use to ATM-1
Standard Sets the trigger to use to Standard
Probe Type

Single-ended Sets the probe type to single-ended.
Differential Sets the probe type to differential.

Bus1 (Trigger Source)

Source

Select the channel source for Bus1. The source selections for a single-ended
probe type are: Ch1-Ch2, Ch1-Ch3, Ch1-Ch4, Ref1, Ref2, Ref3, Ref4.*

The source selections for a differential probe type are: Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Refd.*

Bus Type Select the bus type. The bus type selections are: CAN-DW-LH, CAN-DW-HL,
CAN-SW**, CAN-Fault-T-HL, CAN-Fault-T-LH.
If you use a differential probe, and the positive terminal is connected to a CAN
High signal and the negative terminal to CAN Low, use the CAN-H-L (High-Low)
configuration. If the polarity is reversed, use the CAN-L-H configuration.
If you use a single-ended probe and if Ch1 is connected to a CAN High signal
and Ch2 is connected to a CAN Low signal, use the CAN-H-L (High-Low)
configuration. If you connect Ch1 to a CAN Low signal and Ch2 to a CAN High
signal, use the CAN-L-H (High-Low) configuration.

Bit Rate Set the bit rate of the selected bus type.

Bus2

Source Select the channel source for Bus?2. If you do not have a second bus, set this
option to None.

Bus Type Select the bus type, if applicable.

Bit Rate Set the bit rate for the selected bus type, if applicable.

CAN Node Sensor

Source Sets the CAN node sensor source. For a differential probe, the source
selections are: Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4, None.
For a single-ended probe, the source selections are: Ch1-Ch2, Ch3-Ch4, Ch1-
Ch3, Ch2-Ch4, Ref1, Ref2, Ref3, Ref4, None.

ID Enter or type the ID for which the messages are analyzed.

Analysis Select the type of analysis to perform on the data— Timing or Data. Use Data

for protocol decoding.

* For Ref sources, Timing/Data Analysis is not available.

** For the CAN-SW Bus Type and Single-ended Probe Type, the source channel selection is always Ch1, Ch2, Ch3,
Ch4, Ref1, Ref2, Ref3, Ref4.
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2. Select the probe type.

3. Select the parameters for Bus1 (Source, Bus Type, and Bit Rate). The
selected Bus Type and Data Rate are used to set the Bus Type and Data
Rate of the ATM-1 automotive trigger module.

4. Ifyou have a second bus, select the parameters for Bus2 (Source, Bus
Type, and Bit Rate). If you do not have a second bus, set the Source and
Bus Type to None.

5. Set the CAN Node Sensor Source and ID. If you set the sensor source to
None, the ID field is disabled.

6. Seclect the type of analysis to perform on the data—Timing or Data. Use
Data to decode a protocol.

Note: Usually, timing analysis is used to detect anomalies in the acquired
signal. Data analysis is used for protocol decoding.

7. Click Tests > Trigger Setup to configure the trigger parameters or click
Tests > Connect to make connections to the device under test.

Configure LIN Protocol
Figure 4-4 shows the configuration parameters for the LIN protocol.

File Tests Results Utilities Help TDSYNM B (X

Configure

' Trigger
Select ) DEO-CAN % | Probe Type Differantial ™
! Using

Bus 1 (Trigger Sourcej

Source Bus Type Bit Rate
: I Chi w I LIk - 10kbpz I

Trigger .
|| Setup Bus 2 Analysis
. Source Bus Type Bit Rate b
- & I [rata -
Connect I Mone ™ I Mana - 10kb p= I :

LIM | Busi: Chi; LIM; A0kbps; Bus2: Mone; Mone; 10kbps Fieady

Figure 4-4: Configuring a LIN protocol
Follow these steps to configure the LIN bus.

1.  On the menu bar, click Tests > Configure to configure the parameters for
the selected protocol.

Note: Trigger Using is not applicable to LIN.

30 TDSVNM Timing and Protocol Decode Software



How to ...

Table 4-4 shows the parameters that you can configure for LIN protocol
decoding. You can decode two LIN buses simultaneously.

Table 4-4: LIN protocol configuration paraneters

Parameter Description

Probe Type

Single-ended Sets the probe type to single-ended.
Differential Sets the probe type to differential.

Bus1 (Trigger Source)

Source

Select the channel source for Bus1. The source selections for single-ended and
differential probe types are: Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4.*

Bus Type Set the bus type to LIN.

Bit Rate Set the bit rate for the selected bus type.

Bus2

Source Select the channel source for Bus2. If you do not have a second bus, set this option to
None.

Bus Type Select the bus type to LIN, if applicable.

Bit Rate Set the bit rate of the selected bus type, if applicable.

Analysis Select the type of analysis to perform on the data— Timing or Data. Use Data for protocol

decoding.

* For Ref sources, Timing/Data Analysis is not available.

2. Select the probe type.
3. Select the parameters for Bus1 (Source, Bus Type, and Bit Rate).

4. Ifyou have a second bus, select the parameters for Bus2 (Source, Bus
Type, and Bit Rate). If you do not have a second bus, set the Source and
Bus Type to None.

5. Select the type of analysis to perform on the data (Timing or Data). Use
Data to decode a protocol.

Note: Usually, timing analysis is used to detect anomalies in the acquired
signal. Data analysis is used for protocol decoding.

6. Click Tests > Connect to connect to the device under test.
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Figure 4-5 shows the configuration parameters for the CAN & LIN protocols.
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Fi gure 4-5: Configuring CAN and LIN protocols

Follow these steps to configure the CAN and LIN bus.

1.  On the menu bar, click Tests > Configure to configure the parameters for
the selected protocols.

Table 4-5 shows the parameters that you can configure for CAN and
LIN protocol decoding. You can decode the two buses simultaneously.

Tabl e 4-5: CAN and LIN protocol configuration paraneters
Parameter Description

Trigger Using

DPO-CAN Sets the trigger to use to DPO-CAN

ATM-1 Sels the trigger to use to ATM-1

Standard Sets the trigger to use to Standard

Probe Type

Single-ended Sets the probe type to single-ended.

Differential Sets the probe type to differential.

Bus1 (Trigger Source)

Source

Select the channel source for Bus1. The source selections for a single-ended
probe type are: Ch1-Ch2, Ch1-Ch3, Ch1-Ch4, Ref1, Ref2, Ref3, Ref4.*

The source selections for a differential probe type are: Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Ref4
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Tabl e 4-5: CAN and LIN protocol configuration paranmeters (cont.)

Parameter Description

Bus Type Select the bus type. The bus type selections are: CAN-DW-LH, CAN-DW-
HL, CAN-SW**, CAN-Fault-T-HL, CAN-Fault-T-LH.
If you use a differential probe, and the positive terminal is connected to a
CAN High signal and the negative terminal to CAN Low, use the CAN-H-L
(High-Low) configuration. If the polarity is reversed, use the CAN-L-H
configuration.
If you use a single-ended probe and if Ch1 is connected to a CAN High
signal and Ch2 is connected to a CAN Low signal, use the CAN-H-L (High-
Low) configuration. If you connect Ch1 to a CAN Low signal and Ch2 to a
CAN High signal, use the CAN-L-H (High-Low) configuration.

Bit Rate Set the bit rate of the selected bus type.

Bus2

Source Select the channel source for Bus2.
The source selections available for single-ended and differential probe types
are: Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4, None.

Bus Type Set the bus type to the default (LIN).

Bit Rate Set the bit rate for the selected bus type.

CAN Node Sensor

Source Sets the CAN node sensor source. For a differential probe, the source
selections are: Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4, None.
For a single-ended probe, the source selections are: Ch1-Ch2, Ch3-Ch4,
Ch1-Ch3, Ch2-Ch4, Ref1, Ref2, Ref3, Ref4, None.

ID Enter or type the ID for which the messages are analyzed.

Analysis Select the type of analysis to perform on the data— Timing or Data. Use
Data for protocol decoding.

Fi gure 4-1  ForRefsources, Timing/Data Analysis is not available.

**For the CAN-SW Bus Type and Single-ended Probe Type, the source channel selection is always Ch1, Ch2, Ch3,

Ch4, Ref1, Ref2, Ref3, Ref4.

2. Select the probe type.

3. Select the parameters for Busl (Source, Bus Type, and Bit Rate). Bus1
is always the CAN bus. The selected Bus Type and Data Rate selected
are used to set the Bus Type and Data Rate of the ATM-1 automotive
trigger module.

4. Select the parameters for Bus2 (Source, Bus Type, and Bit Rate). Bus2
is always the LIN bus.

5. Set the CAN Node Sensor Source and ID. If you set the sensor source to
None, the ID field is disabled.

6. Select the type of analysis to perform on the data (Timing or Data). Use

Data to decode a protocol.

Note: Usually, timing analysis is used to detect anomalies in the acquired
signal. Data analysis is used for protocol decoding.
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7. Click Tests > Trigger Setup to configure the trigger parameters or click
Tests > Connect to make connections to the device under test.

Timng Anal ysis Tests

On the menu bar, click Tests > Configure to configure the parameters for the
selected timing analysis test. Figure 4-6 shows the configuration parameters
for the timing analysis tests.
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Configure

Trigger
Setup

Connect

Configure
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Clear

Run Mode

Single W

O=cillatar Talerance | Bus: Ch; CAN-DW-HL; A0kbps | 1D 200 20 0K 08 Ready

Figure 4-6: Configuration paranmeters for timng analysis tests
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In the configure pane, you will see the factory default configuration for the
test you selected. For most tests, you can use the factory default
configuration. However, you can change the values by using the virtual
keyboard or the general purpose knob on the oscilloscope front panel. Using
the File menu, you can also restore the factory defaults or save and recall
your own configuration settings.

The following table shows the parameters that you can configure for timing
analysis tests.
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Bus (Trigger Source)

W
" & - L
EE 5 'E U L gw ]
EZ A =y = EcEFE o -
Ec§ 25 P 5f2ED E =
=l - [ o o T & - [
Qsaollator | ppo-cans Differential Chi, Chz, Ch3, Chd, CAN-DW-LH, 10 kbps-1 Mbps
Tolerance | ATM-1 Refl, Refz, Ref3, Refd | CAN-DW-HL,
<tandard CAM-5W, 10 kbps-100 Kbps
Single-ended | Chi-Chz, Ch3-Chd, CAMN-Fault-T-HL, 10 kbps-125 Kbps
Chi-Ch3, Chz-Chg, CAM-Fault-T-LH
Refl, Refz, Ref3, Refd
Evye DPo-CAnS Differential Chi, Chz, Ch3, Chd, CAN-DW-LH, 10 kbps-1 Mbps
Diiagrarm ATM-1 Refl, Refz, Ref3, Refd | CAMN-DW-HL,
<tandard CAM-5W, 10 kbps-100 Kbps
Single-ended | Chi-Chz, Ch3-Chd, CAMN-Fault-T-HL, 10 kbps-125 Kbps
Chi-Ch3, Chz-Chg, CAM-Fault-T-LH
Refl, Refz, Ref3, Refd
Bus Traffic | ppo-cans Differential Chi, Chz, Ch3, Chd, CAMN-DW-LH, 10 kbps-1 Mbps
ATM-1 Refl, Ref?, Ref3, Refd | CAN-DW-HL,
<tandard CAN-SW, 10 Kbps-100 Kbps
Single-ended | Chi-Chz, Ch3-Chd, CaM-Fault-T-HL, 10 Kbps-125 Khbps
Chi-Ch3, Ch2-Chg, CAMN-Fault-T-LH
Refl, Ref2, Ref3, Refd
Data Rate | ppo-cans Differential Chil, Chz, Ch3, Chd, CAM-D-LH, 10 Kbps-1 Mbps
ATM-1 Refl, Ref?, Ref3, Refd | CAN-DW-HL,
<tandard CAN-SW*, 10 Kbps-100 Kbps
Single-ended | Chi-Chz, Ch3-Chd, CaM-Fault-T-HL, 10 Kbps-125 Kbps
Ch1-Ch3, Chz-Ch4, CAN-Fault-T-LH
Refl, Ref?, Ref3, Refd
it alceup & Differential Chil, Chz, Ch3, Chd, CAMN-D-LH, 10 Kbps-1 Mbps
Time Refl, Ref2, Ref3, Refd | CAN-DW-HL,
CAR-Si* 10 Kbps-100 Kbps
Single-ended | Chi-Chz, Ch3-Chd, CAM-Fault-T-HL, 10 Kbps-125 kKbps
Ch1-Ch3, Ch2z-Chd, CAMN-Fault-T-LH
Refl, Refz, Ref3, Refd
Propagation | MA Differential Chi, Chz, Ch3, Chd, CAN-DW-LH, 10 kbps-1 Mbps
Cielay Refl, Ref?, Ref3, Refd | CAN-DW-HL,
CAN-SW*, 10 Kbps-100 Kbps
Single-ended | Chi-Chz, Ch3-Chd, CAMN-Fault-T-HL, 10 kbps-125 Kbps

Ch1-Ch3, Chz-Chd,
Refl, Ref2, Ref3, Refd

CAN-Fault-T-LH

* For the CAN-SW Bus Type and Single-ended Probe Type, the source channel selection is always Chl, Chz,
Ch3, Chd, Refl, RefZ, Ref3, Refd

& When Trigger Using is set to DPO-CaN, the application supports the standard data rates,

Note: When Ref sources are selected in configuration panel, only the No Acq
sequencer mode is available.

For the Wakeup Time test, only the Single and No Acq sequencer modes are

available.

Standard is not available for timing analysis tests

For two-channel oscilloscopes, source selections Ref3, Ref4, Ch1-Ch3, and
Ch1-Ch4 are not available.
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When Trigger Using is set to DPO-CAN, the application supports the
following standard date rates:

10 Kbps, 20 Kbps, 33.3 Kbps, 50 Kbps, 62.5 Kbps, 83.3 Kbps, 100 Kbps,

125 Kbps, 250 Kbps, 500 Kbps, 800 Kbps, and 1 Mbps.

After you select and configure a protocol or test, you can either set up the
trigger conditions or make equipment connections for the selected protocol or
test.

Configure Oscillator Tol erance

Figure 4-7 shows the configuration parameters for the Oscillator Tolerance
test.
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Figure 4-7: Configuration paraneters for oscillator tol erance test

Follow these steps to configure the Oscillator Tolerance test.

1. On the menu bar, click Tests > Configure to configure the parameters for
the Oscillator Tolerance test. Table 4-6 shows the parameters that you
can configure for the Oscillator Tolerance test.

2. Select the Trigger Using for the DPO oscilloscope.

Table 4-6: Oscillator tolerance configuration paraneters

Parameter Description

Trigger Using

DPO-CAN Sets the trigger to use to DPO-CAN

ATM-1 Sets the trigger to use to ATM-1

Probe Type

Single-ended Sets the probe type to single-ended.

Differential Sets the probe type to differential.
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Table 4-6: Gscillator tolerance configuration paraneters (cont.)

Parameter Description

Bus (Trigger Source)

Source Select the channel source for the bus. The source selections for a
single-ended probe type are: Ch1-Ch2, Ch1-Ch3, Ch1-Ch4, Ref1, Ref2,
Ref3, Ref4.

The source selections for a differential probe type are: Ch1, Ch2, Ch3,
Ch4, Ref1, Ref2, Ref3, Ref4.

Bus Type Select the bus type. The bus type selections are: CAN-DW-LH, CAN-
DW-HL, CAN-SW*, CAN-Fault-T-HL, CAN-Fault-T-LH.
Bit Rate Set the bit rate of the selected bus type.

* For the CAN-SW Bus Type the source channel selection is always Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4.

3. Select the probe type.
4. Select the parameters—Source, Bus Type, and Bit Rate.

5. Click Tests > Trigger Setup to configure the trigger parameters or click
Tests > Connect to make connections to the device under test.

Confi gure Eye Di agram

Figure 4-8 shows the configuration parameters for the Eye Diagram test.

File Tests Results Utilites Help TDSYNM m| x|

Configure

DPO-CAM ™ Probe Type Differential ™
Using P :

Bus (Trigger Source)

Configure Source Bus Type Bit Rate

Ch1 - CAaN-DWM-HL @™ 10kbps

Tii
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Single W

Connect

Eve Diagram | Bus: Chi; CAN-DVSHL; 10kbps | 1D 20 0 0 o Feady

Figure 4-8: Configuration paranmeters for eye diagramtest
Follow these steps to configure the Eye Diagram test.

1. On the menu bar, click Tests > Configure to configure the parameters for
the Eye Diagram test.

2. Select the Trigger Using for the DPO oscilloscope.
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Table 4-7 shows the parameters that you can configure for the Eye
Diagram test.

Tabl e 4-7: Eye diagram configuration paraneters

Parameter Description

Trigger Using

DPO-CAN Sets the trigger to use to DPO-CAN

ATM-1 Sets the trigger to use to ATM-1

Probe Type

Single-ended Sets the probe type to single-ended.

Differential Sets the probe type to differential.

Bus (Trigger Source)

Source Select the channel source for the bus. The source selections for a
single-ended probe type are: Ch1-Ch2, Ch1-Ch3, Ch1-Ch4, Ref1, Ref2,
Ref3, Ref4.
The source selections for a differential probe type are: Ch1, Ch2, Ch3,
Ch4, Ref1, Ref2, Ref3, Ref4.

Bus Type Select the bus type. The bus type selections are: CAN-DW-LH, CAN-
DW-HL, CAN-SW*, CAN-Fault-T-HL, CAN-Fault-T-LH.

Bit Rate Set the bit rate for the selected bus type.

* For the CAN-SW Bus Type the source channel selection is always Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4.
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Select the probe type.
Select the parameters—Source, Bus Type, and Bit Rate.

Click Tests > Trigger Setup to configure the trigger parameters or click
Tests > Connect to make connections to the device under test.
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Configure Bus Traffic

Figure 4-9 shows the configuration parameters for the Bus Traffic test.
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Figure 4-9: Configuration paraneters for bus traffic test
Follow these steps to configure the Bus Traffic Trigger Using selection.

1. On the menu bar, click Tests > Configure to configure the parameters for
the Bus Traffic test. Table 4-8 shows the parameters that you can
configure for the Bus Traffic test.

Table 4-8: Bus traffic configuration paraneters

Parameter Description

Trigger Using

DPO-CAN Sets the trigger to use to DPO-CAN

ATM-1 Sets the trigger to use to ATM-1

Probe Type

Single-ended Sets the probe type to single-ended.

Differential Sets the probe type to differential.

Bus (Trigger Source)

Source Select the channel source for the bus. The source selections for a
single-ended probe type are: Ch1-Ch2, Ch1-Ch3, Ch1-Ch4, Ref1, Ref2,
Ref3, Ref4.
The source selections for a differential probe type are: Ch1, Ch2, Ch3,
Ch4, Ref1, Ref2, Ref3, Ref4.

Bus Type Select the bus type. The bus type selections are: CAN-DW-LH, CAN-
DW-HL, CAN-SW*, CAN-Fault-T-HL, CAN-Fault-T-LH.

Bit Rate Set the bit rate for the selected bus type.

* For the CAN-SW Bus Type the source channel selection is always Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4.

2. Select the probe type.

3. Select the parameters—Source, Bus Type, and Bit Rate.
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4.

Click Tests > Trigger Setup to configure the trigger parameters or click
Tests > Connect to connect to the device under test.

Configure Data Rate

Figure 4-10 shows the configuration parameters for the Data Rate test.
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Figure 4-10: Configuration paraneters for data rate test

Follow these steps to configure the Data Rate test.

1.

On the menu bar, click Tests > Configure to configure the parameters for
the Data Rate test.

Select the Trigger Using for the DPO oscilloscope. Table 4-9 shows the
parameters that you can configure for the Data Rate test.

Table 4-9: Data rate configuration paraneters

Parameter Description

Trigger Using

DPO-CAN Sets the trigger to use to DPO-CAN

ATM-1 Sets the trigger to use to ATM-1

Probe Type

Single-ended Sets the probe type to single-ended.

Differential Sets the probe type to differential.

Bus (Trigger Source)

Source Select the channel source for the bus. The source selections for a
single-ended probe type are: Ch1-Ch2, Ch1-Ch3, Ch1-Ch4, Ref1, Ref2,
Ref3, Ref4.
The source selections for a differential probe type are: Ch1, Ch2, Ch3,
Ch4, Ref1, Ref2, Ref3, Ref4,

Bus Type Select the bus type. The bus type selections are: CAN-DW-LH, CAN-
DW-HL, CAN-SW*, CAN-Fault-T-HL, CAN-Fault-T-LH.

Bit Rate Set the bit rate for the selected bus type.

* For the CAN-SW Bus Type the source channel selection is always Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4.
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3. Select the probe type.
4. Select the parameters—Source, Bus Type, and Bit Rate.

5. Click Tests > Trigger Setup to configure the trigger parameters or click
Tests > Connect to make connections to the device under test.

Confi gure Wakeup Tine

Figure 4-11 shows the configuration parameters for the Wakeup Time test.
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Fi gure 4-11: Configuration paraneters for wakeup tine test
Follow these steps to configure the Wakeup Time test.

1. On the menu bar, click Tests > Configure to configure the parameters for
the Wakeup Time test. Table 4-10 shows the parameters that you can
configure for the Wakeup Time test.

Tabl e 4-10: Wakeup tine configuration paraneters

Parameter Description

Probe Type

Single-ended Sets the probe type to single-ended.

Differential Sets the probe type to differential.

Bus (Trigger Source)

Source Select the channel source for the bus. The source selections for a
single-ended probe type are: Ch1-Ch2, Ch1-Ch3, Ch1-Ch4, Ref1, Ref2,
Ref3, Ref4.

The source selections for a differential probe type are: Ch1, Ch2, Ch3,
Ch4, Ref1, Ref2, Ref3, Ref4.

Bus Type Select the bus type. The bus type selections are: CAN-DW-LH, CAN-
DW-HL, CAN-SW*, CAN-Fault-T-HL, CAN-Fault-T-LH.
Bit Rate Set the bit rate for the selected bus type.

* For the CAN-SW Bus Type the source channel selection is always Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4.
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2. Select the probe type.
3. Select the parameters—Source, Bus Type, and Bit Rate.

4. Click Tests > Trigger Setup to configure the trigger parameters or click
Tests > Connect to make connections to the device under test.

Note: Trigger Using is not available for the Wakeup Time measurement

Confi gure Propagation Del ay

Figure 4-12 shows the configuration parameters for the Propagation Delay
test.
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Figure 4-12: Configuration paraneters for propagati on del ay test
Follow these steps to configure the Propagation Delay test.

1.  On the menu bar, click Tests > Configure to configure the parameters for
the Propagation Delay test. Table 4-11 shows the parameters that you
can configure for the Propagation Delay test.

Tabl e 4-11: Propagation delay configuration paraneters

Parameter Description

Probe Type

Single-ended Sets the probe type to single-ended.

Differential Sets the probe type to differential.

Bus (Trigger Source)

From Source Select the From and To channel sources for the bus. The source

To Source selections for a single-ended probe type are: Ch1-Ch2, Ch3-Ch4, Ch1-
Ch3, Ch2-Ch4, Ref1, Ref2, Ref3, Refd.
The source selections for a differential probe type are: Ch1, Ch2, Ch3,
Ch4, Ref1, Ref2, Ref3, Refd.
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Tabl e 4-11: Propagation delay configuration paraneters (cont.)

Parameter Description

Bus Type Select the bus type. The bus type selections are: CAN-DW-LH, CAN-
DW-HL, CAN-SW*, CAN-Fault-T-HL, CAN-Fault-T-LH.

Bit Rate Set the bit rate for the selected bus type.

* For the CAN-SW Bus Type the source channel selection is always Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4.

2. Select the probe type.
3. Select the parameters—From Source, To Source, Bus Type, and Bit Rate.

4. Click Tests > Connect to connect to the device under test.

Note: Trigger Using is not available for Propagation Delay test

Set up Trigger

Set up Trigger

On the menu bar, click Tests > Trigger Setup to set up the trigger parameters
and conditions for the selected test. You can configure the trigger setup for
the ATM-1 automotive trigger module in the trigger panel.

You can force a trigger by pressing the Single button on the front panel.
Forced trigger is used to observe the sequence of events manually. Click Run
to decode the acquired data in the Single No Acq mode.

Figure 4-13 shows the trigger setup parameters for protocol decoding when
Trigger Using is set to ATM-1.
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Figure 4-13: Trigger setup paraneters for protocol decoding (ATM 1)
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Figure 4-14 shows the trigger setup parameters when Trigger Using is set to
DPO-CAN.
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Figure 4-14: Trigger setup paraneters for protocol decodi ng (DPO CAN)

Figure 4-15 shows the trigger setup parameters when Trigger Using is set to
Standard.
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Figure 4-15: Trigger setup paraneters for protocol decodi ng (Standard)
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The following table shows the Trigger parameters that you can set for
protocol decoding.
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Triggering is not available for LIN,

Figure 4-16 shows the trigger setup parameters for timing tests when Trigger
Using is set to ATM-1.
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Figure 4-16: Trigger setup paraneters for timng tests
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Figure 4-17 shows the trigger setup parameters for timing tests when Trigger
Using is set to DPO-CAN:
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Figure 4-17: Trigger setup paraneters for timng tests when Trigger Using is set
to DPO- CAN
The following table shows the Trigger parameters that you can set for the
timing analysis tests.
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Triggering is not available for the Propagation Delay test.
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Note: If you have set the Sample Point Location to a value such that the
TSEG?2 value is less than the SJW (synchronization jump width), then the
following warning will appear: TSEG?2 is less than SIW. Would you like to
change the Sample Point and run the measurement again?
Choose Yes to change the Sample Point Location in the Trigger panel.
Choose No to continue with the measurement without changing the value of
the Sample Point Location.
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If Trigger Using is set to DPO-CAN, the Trigger-In Source, Sample Point
Location, and ACK trigger parameters are not available.

Trigger CAN and CAN LI N Protocol

On the menu bar, click Tests > Trigger Setup to set up the trigger parameters
and conditions for the selected test. You can configure the trigger setup for
the ATM-1 automotive trigger module in the trigger panel. Figure 4-18 shows
the trigger setup parameters for the CAN and CAN/LIN protocols.

File Tests Results Utiliies Help TDSVNM m| x|

; Trigger Setup
Salect Trigger-In Source Sample Point Trigger Event

Auzin ¥ i Select
e Location L .

i So & Elementan™

Configure ; l-:il_l -

Define

. Trigger

Clear
Setup

Run Mode
es e :
Connect Single ¥

CAM | Busi: Chi; CAN-DW-HL; 10kbps; BusZ: Hone; Mone; 10kbps | Trig On: Cata Frame Ready

Figure 4-18: Trigger setup paraneters for CAN and CAN LI N protocols

Figure 4-19 shows the trigger setup parameters for the CAN and CAN/LIN
protocols when Trigger Using is set to DPO-CAN.

File Tests Results Utilities Help TDSYHM

| x|
Trigger Setup

Trigger On CAHN Type Type of Frame Fornat m

Il and Crata Standard W Hex -

iz bz Data Direction Trigger Events m

Trigger Either W -
Setup :

Run Mode

Connect Single W

CAM & LIN | Busi: Chi; CAN-DW-HL; 10kbps; Bus2: ChZ; LIN; 10kbps | Trig On: Data Frame Feady

Figure 4-19: Trigger setup paraneters for CAN and CAN LIN protocols when Trigger
Using is set to DPO CAN

To set up a trigger event for CAN or CAN & LIN protocols, follow these
steps:

1. From Tests > Select, select CAN or CAN & LIN.

2. From Tests > Configure, configure the CAN or CAN & LIN buses.
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Tabl e 4-12:

3. From Tests > Trigger Setup, set the trigger parameters for the selected
protocol(s). Table 4-12 lists the parameters and their descriptions when
Trigger Using is set to ATM-1.

CAN and CAN'LIN trigger paraneters

Parameter

Description

Trigger-In Source

Used to trigger the oscilloscope. It is the trigger output of the ATM-1 automotive
trigger module that is connected to the trigger-in source.

Set the Trigger-In source to Aux In, Ch1, Ch2, Ch3, or Ch4.

Sample Point
Location Is the location of finding the bit state (0, 1) from the start of the synchronization
segment. Define the sample point location as a percentage of the bit interval.
Trigger Event Select and define the Elementary, Logical, or Advanced trigger event to use.
ACK Used to receive acknowledgement from the ATM-1 automotive trigger module
that behaves as a CAN node.
Set ACK to Yes to receive an acknowledgement from the ATM-1 automotive
trigger module.
Table 4-13 shows the CAN and CAN/LIN trigger parameters when Trigger
Using is set to DPO-CAN.
Tabl e 4-13: Bus traffic trigger parameters for DPO CAN
Parameter Description
Trigger On Select the frame on which to trigger. The selections are: CAN Message, Frame, ID,
Data, ID and Data, EOF, Missing Ack
CAN Type Select the CAN type to use: Standard, Extended
Type of Frame Select the Type of Frame to use: Data and Remote
Format Select binary or hexadecimal as the format you will use to enter ID and Data values

Data Direction

Select the Data Direction to use: Either, Data Frame, and Remote Frame
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4. From Tests > Connect, set up the connections for the bus or buses to
decode.
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Trigger LIN Protocol

Trigger setup is not available (as shown in Figure 4-20) for decoding the LIN
bus. The TDSVNM application uses the edge trigger feature of the
oscilloscope.

File Tests Results Utiliies Help TDSVNM m| x|

Trigger Setup

Configura

o Trigger Setup Configuration is not applicable for this decodingftest.
Trigger

| Setup

Connect

LIN | Busi: Ch1; LIN; 10kbps; Bus2: MHone; Hane; 10kbps Feady

Fi gure 4-20: Trigger setup screen for LIN protocol

Trigger for Gscillator Tol erance, Eye Diagram and
Data Rate

On the menu bar, click Tests > Trigger Setup to set up the trigger parameters
and conditions for the selected test. You can configure the trigger setup for
the ATM-1 automotive trigger module in the trigger panel.

Figure 4-21 shows the trigger setup parameters for the Oscillator Tolerance,
Eye Diagram, and Data Rate tests.

File Tests Results Utilities Help TDSWNM m| x|

Trigger Setup

Calact Trigg_er-lq Sc_ru_n:e Sample Point Input

Location L 1] I_

Configure

Trigger il
Setup  §

Connect

Oscillator Tolerance | Bus: Che; CAN-DW-HL; 10kbps | 1D 206 206 200 220 Ready

Figure 4-21: Trigger setup paraneters for oscillator tol erance, eye diagram and
data rate tests
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Figure 4-22 shows the trigger setup parameters for the Oscillator Tolerance,
Eye Diagram, and Data Rate tests when Trigger Using is set to DPO-CAN.

File Tests Results Utilities Help TDSVNM m| x|
Trigger Setup

Cutrifiz Uz Data Direction m

Trigger Either —
Setup

Run Mode

Single "

Connect

Oscillator Telerance | Bus: Chil; CAN-DW-HL; 10kbps | 1D 200 2 200 XK, Ready

Fi gure 4-22: Trigger setup paraneters for oscillator tol erance, eye diagram and
data rate tests when Trigger Using is set to DPO CAN

To set up a trigger event for Oscillator Tolerance, Eye Diagram, and Data
Rate timing tests follow these steps:

1. From Tests > Select, select Oscillator Tolerance, Eye Diagram, or Data
Rate timing test.

2. From Tests > Configure, configure the selected test.

3. From Tests > Trigger Setup, set the trigger parameters for the selected
test (as shown in Table 4-14). The trigger setup for Oscillator Tolerance,
Eye Diagram, and Data Rate timing tests are identical.

Table 4-14: GCscillator tolerance, eye diagram and data rate
trigger paraneters

Parameter Description

Trigger-In Source Trigger-In Source is used to trigger the oscilloscope. It is the trigger output of the ATM-1
automotive trigger module that is connected to the trigger-in source.

Set the Trigger- In source to Aux In, Ch1, Ch2, Ch3, or Ch4.

Sample Point

Location Gives the location of the bit state (0, 1) from the start of the synchronization segment. Define
the sample point location as a percentage of the bit interval.

Input

ID Type or select the Input ID in Hexadecimal or Binary format. The application generates the
results for this specified ID.

ACK Set ACK to Yes to receive an acknowledgement from the ATM-1 automotive trigger module

that behaves as a CAN node.
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Table 4-15 shows Oscillator Tolerance, Eye Diagram, and Data Rate trigger
parameters when Trigger Using is set to DPO-CAN.

Tabl e 4-15: Gscillator tolerance, eye diagram and data rate
trigger paraneters for DPO CAN

Parameter Description
ID Type or select the Input ID
Data Direction Select the Data Direction to use: Either, Data Frame, and Remote Frame

4. Select the Trigger-In Source.

5. Type or select the Input ID. Data acquisition starts when the application
encounters an ID value that matches the one specified in this field.

6. From Tests > Connect, set up the connections for the bus.

Trigger Bus Traffic

On the menu bar, click Tests > Trigger Setup to set up the trigger parameters
and conditions for the selected test. You can configure the trigger setup for
the ATM-1 automotive trigger module in the trigger panel.

Figure 4-23 shows the trigger setup parameters for the Bus Traffic test.

File Tests Results LUtilities Help TDSYNM m| x|

Trigger Setup

[ Salect . Trigger-In Source Sample Point Trigger Event i m
= . - Select =

Auxin &
Location *

o 1 ®
Configure I 0%

Lrefine

Trigger i

Setup |

ACHK
Connect | n T

Bus Traffic | Bus: Chi; CAN-DW-HL; 10kbp= Ready

Figure 4-23: Trigger setup paraneters for bus traffic test
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Figure 4-24 shows the trigger setup parameters for the Bus Traffic test when
Trigger Using is set to DPO-CAN.

File Tests Results Utilities Help TDSVNM || x|
Trigger Setup

Select Trigger On CAH Type Type of Frame Format m

Il and Crata Standard ™ Hex -

Dot g e Data Direction Trigger Fvents

Trigger Either w Claat
Setup "

Run Mode
Cannect Single W

Bus Traffic | Bus: Chil; CAN-DW-HL; 10kbps Ready

Fi gure 4-24: Trigger setup paranmeters for bus traffic test when Trigger Using is
set to DPO- CAN

To set up a trigger event for Bus Traffic timing test, follow these steps:

1. From Tests > Select, select Bus Traffic timing test.

2. From Tests > Configure, configure the selected test.

3. From Tests > Trigger Setup, set the trigger parameters for the selected

test (as shown in Table 4-16).

Table 4-16: Bus traffic trigger paraneters when Trigger Using is
set to ATM1

Parameter Description

Trigger-In Source Trigger-In Source is used to trigger the oscilloscope. It is the trigger output of the ATM-1
automotive trigger module that is connected to the trigger-in source.

Set the Trigger-In source to Aux In, Ch1, Ch2, Ch3, or Ch4.

Sample Point

Location Gives the location of the bit state (0, 1) from the start of the synchronization segment.
Define the sample point location as a percentage of the bit interval.

Trigger Event Select and define the Elementary trigger event to use.

ACK Set ACK to Yes to receive an acknowledgement from the ATM-1 automotive trigger

module that behaves as a CAN node.
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Table 4-17 shows the Bus traffic trigger parameters when Trigger Using is set
to DPO-CAN.

Table 4-17: Bus traffic trigger paranmeters for DPO CAN

Parameter Description

Trigger On Select the frame on which to trigger. The selections are: CAN Message, Frame, ID,
Data, ID and Data, EOF, Missing Ack

CAN Type Select the CAN type to use: Standard, Extended

Type of Frame Select the Type of Frame to use: Data and Remote

Format Select binary or hexadecimal as the format you will use to enter ID and Data values

Data Direction Select the Data Direction to use: Either, Data Frame, and Remote Frame

4. Select the Trigger-In Source.

5. Define the Elementary trigger event to use.

6. From Tests > Connect, set up the connections for the bus.
Trigger Wakeup Tine

On the menu bar, click Tests > Trigger Setup to set up the trigger parameters
and conditions for the selected test. You can configure the trigger setup for
the ATM-1 automotive trigger module in the trigger panel.

Figure 4-25 shows the trigger setup parameters for the Wakeup Time test.

File Tests Results Utilities Help TDSYNM m| x|

Trigger Setup

Trigger-In Source Wakeup Time
— Settling

Ch1 -

i Latency Time %
: = T .
Configure ; 190ms |

Trigger
: Trigger Level #
Setup | Trigger Slope =
. Rise W Ik

Connact |

Wiakeup Time | Bus: Chi; CAMN-DW-HL; 10kbps | Settling Latency Time: 190ms= Ready

Fi gure 4-25: Trigger setup paraneters for wakeup tine test
To set up a trigger event for Wakeup Time test, follow these steps:
1. From Tests > Select, select Wakeup Time test.

2. From Tests > Configure, configure the selected test.

TDSVNM Timing and Protocol Decode Software 53



How to...

3. From Tests > Trigger Setup, set the trigger parameters for the selected
test (as shown in Table 4-18).

Tabl e 4-18: Wakeup tinme trigger paraneters

Parameter Description

Trigger-In Source Trigger-In Source is used to trigger the oscilloscope. It is the trigger output of
the ATM-1 automotive trigger module that is connected to the trigger-in source.

Set the Trigger- In source to Aux In, Ch1, Ch2, Ch3, or Ch4.

Wakeup Time
Settling Latency Time Set the Settling Latency Time between 190 ns to 240 ns.
Trigger Slope Set the Trigger Slope to Rise or Fall.
Trigger Level Set the Trigger Level between —40 V to +40 V.

4. From Tests > Connect, set up the connections for the bus.

Tri gger Propagation Del ay

Triggering is not available for the Propagation Delay test (as shown in
Figure 4-26).

File Tests Results Ufilities Help TDSVNM m| x|

Trigger Setup

.

i il Trigger Setup Configuration is not applicable for this decodingtest.
Trigger
E

Connect

Fropagation Delay | Bus: Fram Ch1 To ChZ; CAN-DW-HL; 10kbps Ready

Figure 4-26: Trigger setup screen for propagation del ay

Define Elenentary Trigger Events

You can set the Trigger Event to one of the three trigger setups for the ATM-
1 automotive trigger module in the trigger pane (Elementary, Logical, and
Advanced). You can set trigger events to define the trigger out when the
conditions that you have defined are met. Elementary, Logical, and Advanced
triggering are available only for protocol decoding.
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Figure 4-27 shows the settings for Elementary trigger.

& Elementary Trigger Settings

Trigger On

[ata Frame

Figure 4-27:

Tabl e 4-109:

CAH Type Error Type Format

- Standard W

Trigger Events

El ementary trigger settings

Tri

To set up an Elementary trigger event, follow these steps:
1. From Tests > Select, select the protocol to decode.
2. From Tests > Configure, configure the protocol.

3. From Tests > Trigger Setup, set the trigger parameters for the selected
protocol.

Table 4-19 lists the parameters and their descriptions.

gger paraneters

Parameter

Description

Trigger-In Source

Trigger-In Source is used to trigger the oscilloscope. It is the trigger output of the ATM-1
automotive trigger module that is connected to the trigger-in source.

Sample Point

Location Gives the location of the bit state (0, 1) from the start of the synchronization segment.
Define the sample point location as a percentage of the bit interval.

Trigger Event Select and define the Elementary, Logical, or Advanced trigger event to use. Trigger
events are available only for protocol decoding.

ACK Set ACK to Yes to receive an acknowledgement from the ATM-1 automotive trigger

module that behaves as a CAN node.

4. Set the Trigger-In source to Aux In, Chl, Ch2, Ch3, or Ch4.
5. Enter or select the Sample Point in percentage.

6. Set the Trigger Event to Elementary and click Define. The application
displays trigger settings for the elementary trigger event. The trigger
events have conditions or parameters and associated trigger actions.
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Table 4-20 lists the parameters that you can set for an elementary trigger
event.

Tabl e 4-20: Elenentary trigger paraneters

Parameter Description
Trigger On Select the frame on which to trigger. The selections are: CAN Message, ID, Data,
ID and Data, Data Frame, Remote Frame, Error Frame, Overload Frame
CAN Type Select the CAN type to use: Standard, Extended
Error Type Select the Error Type: Active, Passive, CRC, All, Form, Ack. This option is
enabled only when Trigger On is set to Error Frame.
Format Select binary or hexadecimal as the format you will use to enter ID, DLC, and
Data values.
Trigger Events
ID Select the operator that defines whether the ID field in the CAN frame meets a
specified condition. The selections are: =, =, <, <=, > >=Is/in, Is not in.
DLC Enter the data length count (DLC) for that frame (maximum of eight bytes).
Data Select the operator that defines whether the Data field in the CAN frame meets a
specified condition. The selections are: =, 1=, <, <=, >, >=, Is in, Is not in.
Setting some bits in ID and DLC to a Don't Care condition (represented
by Xs) is not allowed. If you do so, you will receive a warning after you
click Apply.
However, Data values can have 'Don't Care' bits.

7.  Select the frame on which to trigger. Based on the trigger type selected,
other options are enabled or disabled. The following table shows the
types of frames that you can select as a trigger source. Based on the
trigger-on source, the other selections change.

Trgger Events
i
g o Loy E m
.n g =R =] TU'
Es i2 E2|E (e |2 |2
CAM Message
G v v v
Crata v v
ID & Data W W s s
Data Frame W W W " "
Rermote Frame v v v
Error Frame: Active, Passive, v v
CRC*, Any, Form®*, Ack**
Cverload Frame

* For the Error Frarme, CRC, the ID trigger event is enabled,

** For Error Frames - Formn and Acle - the fields CAN Type and Format are
enabled, The ID trigger event is also enabled.
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The following table shows the type of frames that you can select as a
trigger source when Trigger Using is set to DPO-CAN:

THgger Events Data
!g 5 E E *E' Direction
£ c E S| 58| s %
= ] = w E a
CaN Message
Frarme v
I v v v v
Data v v
ID & Data v v v v
ECF
Missing Bk

Enter the ID, DLC, and Data values either by typing then in directly in
the field or by using the virtual keyboard. Depending on the selected
format, the virtual keyboard supports hexadecimal or binary input.

When the trigger condition that you have specified is met, the ATM-1
automotive trigger module sends a trigger out to the oscilloscope.

Click OK to confirm the settings and return to the trigger pane.

8. Set ACK to Yes if you want to receive an acknowledgement from the
ATM-1 automotive trigger module.

9. Click Tests > Connect to set up connections to decode the protocol.
Example:
An event can be defined as: “IF <Trigger Condition> THEN <Trigger Out>".

For the bus type CAN-DW-LH with a bit rate of 1 Mbps and trigger set to
Elementary, set the following:

CAN Type: Standard

Trigger on: ID Is In 568 to 658
CAN Type: Standard

Trigger On: Data Frame

ID Is in 500 to 568

DLC=6

Data = 46 XXFF
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Defi ne Logical Trigger Events

In Logical Triggering, you can define more than one condition (up to three
conditions) and set the application to trigger out when any one of the
conditions are met.

Figure 4-28 shows the settings for Logical trigger.

Z  Logical Trigger Settings

Format

Trigger Events
CAHN F

Trigger On

[rata Frame

Trigger On

[rata Frame

Trigger On

[rata Frame

[
B
£
[E
[
[
J
-
[

Canceal

Figure 4-28: Logical trigger settings
To set up a logical trigger event, follow these steps:
1. From Tests > Select, select the protocol to decode.
2. From Tests > Configure, configure the protocol.

3. From Tests > Trigger Setup, set the trigger parameters for the selected
protocol.
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Table 4-21 lists the parameters and their descriptions.

Tabl e 4-21: Trigger paraneters

Parameter Description

Trigger-In Source Trigger-In Source is used to trigger the oscilloscope. It is the trigger output of the ATM-1
automotive trigger module that is connected to the trigger-in source.
Set the Trigger- In source to Aux In, Ch1, Ch2, Ch3, or Ch4.

Sample Point

Location Gives the location of finding the bit state (0, 1) from the start of the synchronization
segment. Define the sample point location as a percentage of the bit interval.

Trigger Event Select and define the Elementary, Logical, Advanced trigger event to use. Trigger events
are available only for protocol decoding.

ACK Set ACK to Yes to receive an acknowledgement from the ATM-1 automotive trigger
module that behaves as a CAN node.

4. Set the Trigger-In source to Aux In, Chl, Ch2, Ch3, or Ch4.

5. Enter or select the Sample Point Location in percentage.

6. Set the Trigger event to Logical and click Define. The application
displays a screen to define the logical trigger event. The trigger events
have conditions or parameters and associated trigger actions.
Table 4-22 lists the parameters that you can set for a logical trigger
event.

Tabl e 4-22: Logical trigger paraneters

Parameter Description

Format Select binary or hexadecimal as the format you will use to enter ID, DLC, and
Data values.

Trigger On Select the frame on which to trigger. The selections are: ID, ID and Data, Data
Frame, Remote Frame, Overload Frame.

CAN Frame

ID Select the operator that defines whether the ID field in the CAN frame meets a
specified condition. The selections are: =, I=, <, <=, > >=Is/in, Is not in.

DLC Enter the data length count (DLC) for that frame (maximum of eight bytes).

Data Select the operator that defines whether the Data field in the CAN frame meets a

specified condition. The selections are: =, =, <=, <, >, >=Isin, Is not in.

Note: The ID can be either Standard or Extended. If the ID value is greater
than an 11-bit value, the ID is considered as an Extended CAN message.

If the Trigger On selection is ID, ID & Data, Data Frame, or Remote Frame,
and operator selected is Is In or Is Not In, and if you enter an ID value
ranging from Standard ID to Extended, then TDSVNM determines the Frame
Type based on the number of bits entered in the 'To’ field.
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Setting some bits in ID and DLC to a "Don't care" condition
(represented by Xs) is not allowed. If you do so, you will receive a
warning message after you click Apply.

However, Data values can have 'Don't Care' bits.

Depending on the format selected, the virtual keyboard supports
hexadecimal or binary input.

7.  Select the frame on which to trigger. Based on the trigger type selected,

other options are enabled or disabled. The following table shows the
types of frames that you can select as a trigger source. Based on the
trigger-on source, the other selections change.

Trgger Events
5
: :

m

(=] [
- o | &
Fa £l1e |a|a
(] v W
I and Data ¥ v s
[rata Frame v v v v
R ermote Frame v v
Cwerload Frame v
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When the trigger condition that you have specified is met, the ATM-1
automotive trigger module sends a trigger out to the oscilloscope.

Click OK to confirm the settings and return to the trigger pane.

8. Set ACK to Yes to receive an acknowledgement from the ATM-1
automotive trigger module.

9. Click Tests > Connect to set up connections to decode the protocol.
Example:

An event can be defined as: “IF <Trigger Condition> OR <Trigger
Condition> OR <Trigger Condition> THEN <Trigger Out>".

A logical trigger condition can be set as:
Trigger On: Data Frame
ID=xxxx, Data: 46 39 EF CB 34
DLC=xxxx

OR
Trigger On: Overload Frame

OR

Trigger On: Remote
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ID=xxxXxX

Def i ne Advanced Tri gger Events

In Advanced triggering, you can define parameters for complex or advanced
trigger conditions and actions for a maximum of three sequences. In each
sequence, for a defined combination of trigger parameters, using the If Then
Else condition, you can set one or more events to occur. For example, “IF
<Trigger Condition> THEN <Trigger Actions> ELSE-IF <Trigger
Condition> THEN <Trigger Actions>". You can loop back from one
sequence to the other, for instance, from Seq#2 the trigger action (“then”
part) can direct to Seq#1.

Figure 4-29 shows the settings for Advanced trigger.

i Advanced Trngger Settings

Format
Trigger
Trigger Sequence #
It

Seq #1 Trigger On [rata Frame Tt oLe I_ .

Sequence

= -

H
~ [

Then

Action #1 |  Triggerout ™ Action #2 | Hone ¥  Action #3 | None

- : Else If
Trigger On [ata Frame - pLC I_
D - |_ o I—
§ £

Data o

Action # : Tri!;!;er-':-ljt *  Action #2 | ¥  Action #3 |

Cancel

Fi gure 4-29: Advanced trigger settings
To set up an advanced trigger event, follow these steps:
1. From Tests > Select, select the protocol to decode.
2. From Tests > Configure, configure the protocol.

3. From Tests > Trigger Setup, set the trigger parameters for the selected
protocol.
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Table 4-23 lists the parameters and their descriptions.

Tabl e 4-23: Trigger paraneters

Parameter Description

Trigger-In Source Trigger-In Source is used to trigger the oscilloscope. It is the trigger output of the ATM-1
automotive trigger module that is connected to the trigger-in source.

Sample Point

Location Gives the location of finding the bit state (0, 1) from the start of the synchronization
segment. Define the sample point location as a percentage of the bit interval.

Trigger Event Select and define the Elementary, Logical, or Advanced trigger event to use. Trigger
events are available only for protocol decoding.

ACK Set ACK to Yes to receive an acknowledgement from the ATM-1 automotive trigger

module that behaves as a CAN node.

4. Set the Trigger-In source to Aux In, Chl, Ch2, Ch3, or Ch4.
5. Enter or select the Sample Point Location in percentage.

6. Set the Trigger event to Advanced and click Define. The application
displays a screen to define the advanced trigger event. The trigger events
have conditions or parameters and associated trigger actions.

Table 4-24 lists the parameters that you can set for an advanced trigger
event.

Tabl e 4-24: Advanced trigger paraneters

Parameter Description

Format Select binary or hexadecimal as the format you will use to enter ID, DLC, and
Data values.

Trigger Sequence #

If/Else If

Trigger On Select the frame on which to trigger. The selections are: ID, ID and Data, Data
Frame, Remote Frame, Overload Frame.

ID Select the operator that defines whether the ID field in the CAN frame meets a
specified condition. The selections are: =, =, <=, >, >=,Isin, Is not in.

DLC Enter the data length count (DLC) for that frame (maximum of eight bytes).

Data Select the operator that defines whether the Data field in the CAN frame meets a
specified condition. The selections are: =, =, <=, >, >=, Is in, Is not in.

Then

Action #1 Set the action to any one: Trigger Out, Start Timer#1, Start Timer#2, Stop

Timer#1, Stop Timer#2, Reset Counter#1, Reset Counter#2, Inc Counter#1, Inc
Counter#2, Dec Counter#1, Dec Counter#2, Go To Seq#1, Go To Seg#2, Go To
Seq#3.

Action #2 Set the action to any one: None, Trigger Out, Start Timer#1, Start Timer#2, Stop
Timer#1, Stop Timer#2, Reset Counter#1, Reset Counter#2, Inc Counter#1, Inc
Counter#2, Dec Counter#1, Dec Counter#2, Go To Seq#1, Go To Seg#2, Go To
Seq#3.
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Tabl e 4-24: Advanced trigger paranmeters (cont.)

Parameter Description

Action #3 Set the action to any one: None, Trigger Out, Start Timer#1, Start Timer#2, Stop
Timer#1, Stop Timer#2, Reset Counter#1, Reset Counter#2, Inc Counter#1, Inc
Counter#2, Dec Counter#1, Dec Counter#2, Go To Seq#1, Go To Seg#2, Go To
Seq#3.

Note: The ID can be either Standard or Extended. If the ID value is greater

than an 11-bit value, the ID is considered as an Extended CAN message.

If the Trigger On selection is ID, ID & Data, Data Frame, or Remote Frame,

and operator selected is Is In or Is Not In, and if you enter an ID value

ranging from Standard ID to Extended, then TDSVNM takes the Frame Type
based on the number of bits entered in the 'To' field.
Setting some bits in ID and DLC to a "Don't care" condition
(represented by Xs) is not allowed. If you do so, you will receive a
warning message after you click Apply.
However, Data values can have 'Don't care' bits.
Depending on the format selected, the virtual keyboard supports
hexadecimal or binary input.

7. Select the sequence using the Seq#1, Seq#2 or Seq#3 buttons. For each
sequence, you can set the CAN Type, Format, and define the Trigger
Sequence.

8. Select the frame on which to trigger. Based on the trigger type selected,
other options are enabled or disabled. The following table shows the
types of frames that you can select as a trigger source. Based on the
trigger-on source, the other selections change.

Trigger Events

L=}

= i
- "
E& i a | a
I v v
ID and Data v v v
Data Frame v v v v
Rernote Frame v ¥
Overload Frame ¥

9. For each trigger sequence define the trigger events.

For a selected Trigger On source and trigger events, use the If-Then-Else
condition to set one or more actions. You can define Action#1,
Action#2, and Action #3 to any of the available selections. When the
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trigger condition that you have specified is met, the external trigger
module sends a trigger out to the oscilloscope.

Click OK to confirm the settings and return to the trigger pane.

10. Set ACK to Yes to receive an acknowledgement from the ATM-1
automotive trigger module. Otherwise, set ACK to No.

11. Click Tests > Connect to set up connections to decode the protocol.
Example:

An advanced trigger event can be defined as:

Seq 1:

If

Trigger on: ID = 568,

Actionl: Go to Sequence 2 Action2: None Action3: None
Else If

Trigger on: None

Seq 2:

If

Trigger On: Remote Frame ID = 555

Actionl: Start Timerl, Action2: Go to Sequence 3, Action3: None
Else if

Trigger On: None

Seq 3:

If

Trigger On: ID =555,

Actionl: Trigger Out, Action2: None, Action3 : None

Else If

Trigger On, Timerl >= Ssec

Actionl: Trigger Out, Action2: None, Action3: None
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Connect

Connections for Protocol and Timng Tests

To carry out protocol and timing analysis tests, connect the oscilloscope,
CAN or LIN bus and ATM-1 automotive trigger module as given in the
following sections.

Connections for CAN Dual Wire
Connections for CAN Single Wire
Connections for CAN Fault Tolerant
Connections for LIN

Connections for CAN and LIN Protocols

Note: Propagation Delay and Wakeup Time tests do not require the ATM-1
automotive trigger module.
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Connections for CAN Dual Wre

On the menu bar, click Tests > Connect to make connections for protocol

decoding.

To carry out CAN Dual Wire Protocol and timing analysis tests, connect the
oscilloscope, CAN bus and ATM-1 automotive trigger module as shown in
Figure 4-30 and Figure 4-31.

CAN-DW-HL probe connection

Trigger out

Rear panel

use Tternal power supply
=

USE cable
Side panel Tektronix oscilloscope
e [ ¢ ] .
30" - g === c Trigger out
o |-
—— . =iEolEEE o
e a = tes L
[ | Ch O O G
i) hi ¢_hl Lhi \'-‘M e
T |
G 1 CAN_L
S CAN bus
4] 3 . eaH

13001

noda 1 node n

Fi gure 4-30: Connections for CAN DWHL
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CAN-DW-LH probe connection

Rear panel

Trigger out usB

xternal power supply

-

&

USE cable /
Tektronix oscilloscape
Sldfingane! o ; o, %, ATM-1 Automgtive trigger module
| B=====0o Trigger out “, B .
EII SI-D ) "1 2 1 4 3 & 7B 3 ooz
£ b_\o:—z E " Nalelelslalnlalelelalale
‘. o 0IEER e 3 3
.‘T-M | i :j g ZI' ?i _{- — L \u .I.G. .17. -1; 1 ;r; .zl. .:z. .uf 24 \r: A
h €hi Chi o3 O
T | S
+]|~ CAN_L
...................... :
S CAN bus g
= : CAN_H -

Figure 4-31: Connections for CAN-DWLH

To carry out CAN Dual Wire Protocol and Timing Analysis tests using DPO-

CAN bus trigger, connect the CAN bus to the oscilloscope as in Figure 4-32
and Figure 4-33.
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CAN-DW-HL probe connection

Tektronix oscilloscope

3

= ~[+ CAN_L
..................... :
g } CAN bus g
] CAN_H =

foda n

Fi gure 4-32: Connections for CAN-DWLH when Trigger Using is set to DPO CAN

CAN-DW-LH probe connection

Tektronix oscilloscope

BEd==m

e o B2 =

E-.O:: g0

o= eSS
J SR ReNe!
i Chi_ond Cnd_Cnd

+1]- CAN_L

P 3 SRS FE :
S CAN bus S
o - CAN_H =

Bl

node 1

Fi gure 4-33: Connections for CAN-DWLH when Trigger Using is set to DPO CAN
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Connections for CAN Single Wre

On the menu bar, click Tests > Connect to make connections for protocol
decoding.

To carry out CAN Single Wire Protocol and timing analysis tests, connect the
oscilloscope, CAN bus and ATM-1 automotive trigger module as shown in
Figure 4-34.

CAN SW probe connection

Rear panel
Trigger out UsB rcternal power supply
T o
o
b =
USB cable |
: Tektronix oscilloscope
I
S'di‘:"“ ) ', ATM-1 Automative trigger module
- ==ocog|| [T %,
l:h:|'r B3 o gger out \ .
4 - é 5 ="_0 & — - _ 25-pin connector .
[r="n o=pSe = N IZ\}O!H?I!NIIL‘I“"
= o
Chi Ch2 On3  Cha {
i (@ ‘ Do oo ms omomomomw m
ke J
A
% CAN_SW

Common ground

ﬁ

Figure 4-34: Connections for CAN SW

To carry out CAN Single Wire Protocol and Timing Analysis tests using
DPO-CAN bus trigger, connect the CAN bus to the oscilloscope as in
Figure 4-35.
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CAN SW probe connection

Tektronix oscilloscope

Cool
1

ok

=
;
(=]
P
o]
Lhi ChZ

Common ground

node 1 node n

Fi gure 4-35: Connections for CAN SWwhen Tri gger
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||||_

Using is set to DPO CAN
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Connections for CAN Fault Tol erant

On the menu bar, click Tests > Connect to make connections for protocol

decoding.

To carry out CAN Fault Tolerant Protocol and timing analysis tests, connect
the oscilloscope, CAN bus and ATM-1 automotive trigger module as shown

in Figure 4-36 and Figure 4-37.

CAN FT-HL probe connection

Rear panel

Trigger aut USE Extermal powear supply

U=B cable
I Tektronix ascilloscope
Sid I
I :.:.T = ATMFL Automdtive trigger medule
- £ Trigger aut
) 825 =2 ::_> 199
g g é:-"c-: i | 25-pin cannactor
e R 7 )
= e g e T
chl hg o cha
T L +4——Vhat—»
Nominal : 12 V
Max : 35 W
CAaN bus
Comman ground

CAN_H —_—i

node 1 node n

Fi gure 4-36: Connections for CAN FT-HL
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USE  External power supply

Rear panel

CAN FT-LH probe connection

How to...
Trigger aut

U=B cable
I Tektronix ascilloscope
Sid I
I e._.T - ATMEL Automdtive trigger module
?..J P — B [ Trigger out
» = a3
C g é_ﬂ..; _— i 25-pin connector
o R ] 5 ;
= s Mo Re e - n 0
fh) fhy ohi Che
T | +4——Vbat ——»
Naminal ; 12 ¥
Max : 35 W
Commen ground

- &

node n

node 1

To carry out CAN Fault Tolerant Protocol and Timing Analysis tests using
DPO-CAN bus trigger, connect the CAN bus to the oscilloscope as shown in

Fi gure 4-37: Connections for CAN FT-LH
Figure 4-38 and Figure 4-39:
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CAN-FT -HL probe connection

Tektronix oscilloscope

il | i CAN_L
..................... y,
g ‘ CAN bus g
o : AR e CAN_H =

node n

Figure 4-38: Connections for CAN FT-LH when Trigger Using is set to DPO CAN

CAN- FT -LH probe connection

Tektronix oscilloscape

n120 5
w
>
=
= S
g -
@

L1200 -

node n

Figure 4-39: Connections for CAN FT-LH when Trigger Using is set to DPO CAN
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Connections for

LI N Prot ocol

On the menu bar, click Tests > Connect to make connections for protocol

decoding.

To decode the LIN protocol, connect the oscilloscope and the LIN bus as

shown in Figure 4-40.

LIN probe connection

Tektronix oscilloscope

3 o n0oCo
Qoo
oo
T E
9 Slo mio

LIM
MASTER

B
T—“; LIN bus

LIN slavea LIN slave

Figure 4-40: Connections for LIN
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Common ground

i

LIN slave
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Connections for CAN and LIN Protocols

On the menu bar, click Tests > Connect to make connections for protocol
decoding.

To decode the CAN and LIN protocols simultaneously, connect the
oscilloscope and the buses as shown in Figure 4-41.

CAN and LIN probe connection
Rear panel
Tliwsr out USE Tmemal power supply
&

#

h L -
Ny

USS cable’ |

Tektranix oscilloscape |
Soepend; ; | ATMIT Autemalive trigger madule
Tri b
ﬁﬂ. - rigger oul \¢ 1
I a =
= ==
= (S N
LIN
MASTER
ah +ab )
- R ;
z
g LAl Gateway LIN bus
el 0 D S CANH ... | - Common ground
ode 1 ode
el fofen LIN siave 1 LIN slave n

Figure 4-41: Connections for CAN and LIN protocols

To decode the CAN and LIN protocol simultaneously using DPO-CAN bus
trigger, connect the CAN bus to the oscilloscope as shown in Figure 4-42.

CAN and LIN probe connection

Tektronix oscilloscope

BmolfE e
aE0==T o
(=l e b =g = |
I I3 ch ¢h
o (=T} B.] |'_IJ [u
o & 1 § §_~_. LIN
) MASTER
I
L e . \-\I
+1] - CAN_L R, R vy e
‘l:._ """""""""
CAN bus
2 Gateway LIN bus
L‘_._ ..... CAN H B s g e Common ground
nodey: | nodeim: LIN slave 1 LIN slave n

Figure 4-42: Connections for CAN and LIN protocols when Trigger Using is set to
DPO- CAN
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Vi ew Results

76

Resul ts W ndow

On the menu bar, click Results > Details to view the results of the selected
protocol or test.

If you chose protocol decoding in the selection panel, then the result
window shows the View Protocol Listing button. Click on this button to
display the results of protocol decoding in the Protocol Analysis
Window. If you chose the Advanced Trigger option, then the Timerl,
Timer2, Counterl, and Counter2 values are also displayed.

For the Oscillator Tolerance test, the window displays the Tolerance
range (minimum, maximum, and average) values. The results are shown
with and without the Ack bit.

For the Eye Diagram test, click the View Eye Diagram button to display
the Eye Diagram plot. The plot has an option to view the Eye Diagram
with or without the Ack bit used during clock recovery.

For the Bus Traffic test, the window displays two tabs: Load and Frame
Count. The Load tab displays the Load value (%) and the Bus
Occupancy pie chart. The Frame Count tab displays the individual frame
count and the total.

For the Data Rate test, the window displays the Data Rate range
(minimum, maximum, and average) values. The results are shown with
and without the Ack bit.

For the Wakeup Time test, the window displays the Wakeup Time value.

For the Propagation Delay test, the window displays the Propagation
Delay value.
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Prot ocol Anal ysis W ndow

On the menu bar, click Results > Details to view the results of the selected
protocol.

When the external trigger module triggers the oscilloscope with a predefined
trigger condition, the waveform on the source channel is acquired. The signal
is decoded into CAN or LIN frames or messages. Each CAN or LIN frame
has a header, control bits, and the data bytes associated with it.

To analyze the signal conveniently, the CAN and LIN message frames are
listed in a tabular format. The table structure and its features are displayed on
a control window called the Protocol Analysis Window. The protocol
analysis window is not available for timing analysis tests.

The Protocol Analysis window provides the ability to analyze two bus signals
simultaneously.

Figure 4-43 shows the protocol analysis window and its areas.

£ protocol Analysis i o] |
op D 1 2 a e D ele ed Ro E Ero e D D e 1 D
Taalbar Zoom ZoomZ2 & & -' m B} & Trlg ,‘.
Frame
00 aue ENS0 i
Search Filter (=10 Link off Configure Haif
Screan
i } Readouts
4 [} Proto z or R Protocol Ana or R
DATA ES éTIh.-1E:E:T.»':=.h.-1 F|l ERROR
1F345987| 6976466 2. O 0.00s | 12 0103 82.4862ms -
Markers ; 123 ozeoeds.| o [ 11871Ims - 34 0102 01..) 90633ms
[ 1F345087 | BAYEE5 2. 0O 21.242ms 12 0103 125 94ms
1F345987 | BA7FE55 2. O 32.912ms a4 010201 ... 14497 ms
127 217609 45| O 44 583 ms 27 040204 ... 210.80ms Listing
123 125427 3...| O 52.557Tms 34 010201 .. 22121ms >
1F345087 | BAYEE5 2. 0O G2.028ms 12 0103 324.16ms
127 217609 46| 0 F3.699ms a4 010201 ... 33228ms
12 0103 360.36ms
34 010201 ... 277.10ms
27 040204 .. 497 61ms r
= e T ﬁ /
>Wavef0 m

Fi gure 4-43: Protocol
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Table 4-25 describes the areas of the protocol analysis window.

Tabl e 4-25: Protocol anal ysis wi ndow areas

Area Description
Toolbar Displays the various controls to analyze the listed frames. You can expand or collapse the
toolbar using Hide/Show Controls button.
Readouts Displays the readouts of the Markers and the time difference between them.
Listing Displays the listing of the decoded frames in the table structure.
Markers Displays the markers associated with listing (M1 and M2).
Waveform Displays the waveform corresponding to the selected row in the listing.
Toolbar

The buttons that are available on the toolbar are described in Table 4-26.

Tabl e 4-26: Protocol analysis w ndow tool bar buttons and
descriptions

Toolbar buttons Action

Sync Scope to Selected Row Select a message on the protocol analysis window. Click Zoom1 or Zoom2.
This places the cursors and zooms the waveform on the oscilloscope to the

Zoomz . L

frame selected in the protocol analysis window.

Zoomd

Put Marker on Selected Row Select a message on the protocol analysis window. Click M1. Select another
m m m message and click M2. This places the markers, M1 and M2 on the selected
messages. For the second listing (in dual listing), use the M3 and M4 markers.

Click M1 to set the M1 message's timestamp to 0.0 sec. TO now overlaps with

Set Zero Timestamp to

, M1.
Trig
Frame Click Trig Frame to set the T (default trigger frame) message's timestamp to
0.0 sec. TO now overlaps with T.
Hide Controls Click this button to show or hide the toolbar controls.

Click Search to open a dialog box and define the search criteria. You can
search for message(s) based on ID, Data, IDE and Remote Frames (RTR bit
Tools is used to search for Remote frame). For a LIN bus, the search fields are ID

W |
Click Filter to open a dialog box and define the filter criteria. You can filter and

view message(s) based on ID, Data, IDE and Remote Frames. For a LIN bus,
the search fields are limited to ID and Data.

Click CSV to save the decoded protocol frames as a CSV (comma separated
variable) file.

Links the decoded CAN message to YT display of the CAN frame and then to
Show Sensor Wim the transducer output waveform. Link the analog waveform from the protocol

analysis window by pressing Link button (in Show Sensor Wfm). This places
the cursor on the waveform. The protocol analysis window is displayed in the

half-screen mode.
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Tabl e 4-26: Protocol
descriptions (cont.)

anal ysi s wi ndow t ool bar buttons and

Toolbar buttons

Action

Stuff Bit YWm

The Stuff Bit Wfm is applicable only to CAN messages.

Select a Ref waveform from the list. Click On to add stuff bits to the selected

destination reference waveform. Bit stuffing is active between SOF and CRC
fields (minus delimiter). The protocol analysis window is displayed in the half-
screen mode.

view

o Halt
ontigure Screen

Click Configure to open a dialog box and configure the protocol analysis
window to show one or two buses (for dual listing), marker readouts, display
waveform, link timestamps (for dual listing), and the decoded data format.

Click Half Screen to display the Protocol Analysis window in the half-screen
display mode.

Note: Zoom?2 is not available on the oscilloscope models TDS7054 and
TDS7104 with firmware version lower than 2.5.3.

Readouts

The protocol analysis window displays the timestamps for the messages
associated with M1 and M2, and the time difference between the two cursors.

You can hide the readouts by using “X” button.
Listing

The protocol analysis window display is available only for protocol decoding.
If you decode only one bus, the protocol analysis window shows the decoded
listing of one bus. All the message fields are shown.

If you decode two buses, the protocol analysis window shows the individual
listing or combined listings of the buses. The individual listing shows all the
message fields.

The individual listing shows the following fields:

®  CAN message fields: ID, IDE, RTR, DLC, DATA, CRC, CRC DEL
ACK, ACK DEL, TIMESTAMP and FRAME INFO

®  LIN message fields: ID, ID FIELD, FRAME TYPE, DATA,
CHECKSUM, TIMESTAMP and ERROR

The combined listing shows the following selected fields:

®  CAN message fields: ID, DATA, ACK, TIMESTAMP and FRAME
INFO

®  LIN message fields: ID, DATA, TIMESTAMP and ERROR
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£ Protocol Analysziz

Sync Scope to Selected Row

Zoom

Zoomz

Markers

Use markers to mark a particular message frame on the listing and get the
time difference between the frames. The following markers are available for a
listing:

" MI (or M3; for simultaneous listings)

" M2 (or M4; for simultaneous listings)

B TO (the zero timestamp reference): The TO row is highlighted by default.
® T (The immovable marker for the triggered frame on the oscilloscope)
You can place the markers in one of the following ways:

®  Hold and drag the marker (using the mouse) to the required message
frame on the protocol analysis window

B Right-click and select from the shortcut menu
Waveform

The message frame for the selected message (row) is plotted at the bottom of
the listing window. The plot is reconstructed when the message selection
changes. The plot shows the message components with labels corresponding
to the protocol frame. The fields are divided as Header, Control, Data, and
Delimiter. Data and Remote frames can be displayed. If the selected frame is
an Error frame, then all fields except Data and CRC will not be displayed.

Hal f - Screen W ndow Di spl ay

Figure 4-44 shows the protocol analysis window in the half-screen mode.

Put Marker on Selected Row Set Zero Timestamp to

& 38

-- CAH-DW Protocol Analysis for Ref1

Fi gure 4-44: Protocol

80

anal ysis wi ndow in the

hal f - screen node

M!I' 123 u] u] 2 |02T2ES T3F9 1 u] 1 12.468ms DATASTD
127 u] u] 4 |21 76 09 46 AR 1 u] 1 20.74949mz DATASTD
127 u] u] 4 |21 76 09 46 A A 1 u] 1 28.720ms DATASTD
1F245987 [ 1 u] G |69 TG S6 2400 20 5158 1 u] 1 36.692ms DATAEXT
127 u] u] 4 |21 7609 46 GA1A 1 u] 1 42.3649ms DATASTD
127 u] u] 4 |21 7609 465 GA1A 1 u] 1 56.3490ms DATASTD :ﬂ
4720 [ul [a] ~ 4% EA OTFT 04 50 00 TN 4 [a] 4 RA 24D - FATH OTH L

The protocol analysis window is shown in half-screen display when you want
to synchronize the selected message to the oscilloscope waveform in time
domain.
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mMowve M1 Here
Move M2 Here

Sync to Zoom
Sync to foom?2
Link Sensor vim

Search

Filter

The half-screen mode is displayed when you:

®  (Click the buttons (Zoom1 or Zoom?2) grouped under Sync Scope to
Selected Row

®  (Click the Link button in the Show Sensor Wfm group
®  (Click the On button in Stuff Bit Wfm

The protocol analysis window is automatically displayed in the half-screen
mode overlaying the application's main window.

By default, in the half-screen mode, you can view the selected row. The table
height reduces and a scroll bar appears.

Full
Click |/ Sereen | or [O1 to restore the full screen display of the analysis

window.

Shortcut Menu

The shortcut menu available on a right-click in the Protocol Analysis window
is as shown in Figure 4-45.

Fi gure 4-45: Shortcut menu

Table 4-27 lists the menu items and their descriptions.

Tabl e 4-27: Shortcut nmenu itens and their descriptions

Menu Selection

Description

Move M1 Here

Moves Marker1 to the location of the mouse pointer in the Protocol Analysis window.

Move M2 Here Moves Marker2 to the location of the mouse pointer in the Protocol Analysis window.

Sync to Zoom!1 Zooms the selected frame of waveform on the oscilloscope.

Sync to Zoom?2 Zooms the selected frame of waveform on the oscilloscope.

Link Sensor Wfm Links the decoded CAN message to YT display of the CAN frame and then to the
transducer output waveform.

Search Opens a dialog box where you can define the search criteria.

Filter Opens a dialog box where you can define the filter criteria.

TDSVNM Timing and Protocol Decode Software 81



How to...

Search

From the protocol analysis window toolbar, click the Search button (grouped
under Tools). A dialog box opens where you can define the search criteria.
Figure 4-46 shows the Search window.

Define Search for Busl
Search Definition

_SearchOn_
| I -

o -_
i

Fi gure 4-46: Search w ndow

Follow these steps to define a search.

1. From Search On, select the field to search on. The fields are: ID, Data,
IDE(0), IDE(1), RTR(0), and RTR(1). For a LIN bus, the search fields
are limited to ID and Data.

2. Select the operator. An operator is available only for ID and Data fields.
The operators are: =, =, <, <=, >, >=, Is In, and Is Not In.

3. Inthe first field, enter a value. For range operators (Is-in and Is-not-in),
select the To value as well.

4. Click Search.

5.  Click the Previous button to highlight and navigate through the previous
messages that satisfy the search definition. The Previous button is
disabled if the highlighted message is the first message.

Click the Next button to highlight and navigate through the next
messages that satisfy the search definition. The Next button is disabled if
the highlighted message is the last message. When no message meets the
search criteria, the following message appears: The Search/Filter
condition is not satisfied.
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Filter

From the protocol analysis window toolbar, click the Filter button (grouped
under Tools). A dialog box opens where you can define the filter criteria.
Figure 4-47 shows the Filter window.

Define Filter for Busl
Filter Definition

Filter On
D -

Figure 4-47: Filter w ndow
Follow these steps to define a filter.

1. From Filter On, select the field to filter on. The fields are: ID, Data, IDE
and RTR. For a LIN bus, the fields available are ID and Data.

2. Select the operator. The operators are: =, |=, <, <=, >, >= s In, and Is
Not In.

3. Inthe first field, enter a value. For range operators (Is-in and Is-not-in),
select the To value as well.

4. Click the Apply button to apply the filter definition. Click the Clear
button to show all the messages without filtering. When no message
meets the filter criteria, the following message appears: The
Search/Filter condition is not satisfied.
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Configure View

From the protocol analysis window toolbar, click the View Configure button.
A dialog box opens where you can configure the view. Figure 4-48 shows the
Configure View window.

Configure Yiew
Lizting Configuration Window

Select Bus
ﬂ Show haker Readouts

[ Link: Timesiamps [ show Wiavetorm

Format

Select

Hezx

Cancel
|

Fi gure 4-48: Configure View w ndow

®  Select a bus (Busl, Bus2, or Both) from the Listing Configuration
group. If you select Both, Link Timestamps is enabled. For a dual
listing, select Link Timestamps to link a row in one listing to the
corresponding row in the other listing.

®  Select Show Marker Readouts and Show Waveform from the Window
group to show/hide marker readouts and waveform.

B Select the Format (Binary or Hex), to display the decoded values.

Note: When simultaneous listings are shown, the Format option is disabled
(displaying Hex).
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Results for CAN Protocol
Results > Details

Once the protocol is decoded, the results are automatically displayed.
However, you can also select Results > Details and click Protocol Listing to
view the results.

Figure 4-49 shows the results of CAN protocol decoding.

File Edit ‘Wertical Horizfacg Trig  Display Cursors  Measure  Masks  Math  MyScope  Utlities  Help

Sync Scope to Selected Row Put Marker on Selected Row Set Zero Timestamp to Show Contre

Tri

-- CAH-DW Protocol Analysis for Chi

? L DEL m L MESTAMP || FRAME INFO
127 u] 4 |21 7609 46 AA 1 u] 1 0.00s DATASTD H
127 u] u] 4 | 217G 09 46 AA 1 u] 1 2.0381ms DATASTD
M1 127 u] u] 4 | 217G 09 46 AA 1 u] 1 28 738ms DATASTD
127 u] u] 4 | 217G 09 46 AA 1 u] 1 27 76dms DATASTD
127 u] u] 4 |21 7609 46 AA 1 u] 1 37 047 ms DATA-STD
123 u] u] 3 |02 7265 TaFQ 1 1 42 528ms DATASTD _ll
422 [a] [n] ] 472 £A OF 204 90 97 Lackaul 4 [a] 4 R TTT e PATA CTH

Figure 4-49: Results of CAN protocol
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If you chose Advanced Trigger event in Trigger Setup, the results include the
Counter and Timer values as shown in the Figure 4-50.

File Edit Wertical Horizfdcq Trig  Display  Cursors  Measure  Masks  Math  MyScope  Ukilities Help

e

|
T
|

——

pu o
I o
i
_|,.
+-
e
T
by
mm

File Tests Results Utilities Help | TDSVNM |y x|

Protocol Decoding

Salact
Counter/Timer Values

Configure Counter1: : Results

Counter2: Mot Used

Tii
St " Clear
Setup Timer1: <, Zms !
Timer2: Haot Used :
Connect Single "

CAMN | Busi: Chi; CAN-DWMU-HL; 10kbps; BusZ: None; None; 10kbps | Trig Event: Advanced

Figure 4-50: Results of CAN protocol wth advanced triggering
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Results for LIN Protocol
Results > Details

Once the protocol is decoded, the results are automatically displayed.
However, you can also select Results > Details and click Protocol Listing to
view the results.

Figure 4-51 shows the results of LIN protocol decoding.

<= Protocol Analysis - i ] [ |

op 0 d o H 7 &I D d Ro = Ero = : 0 1o de 0 0
Tri
Zoom Zoomz g} & & & - ‘.
Frame
00 ave = 0 H E
= 2 5 Half
Search Filtar [s=1¥) Lt L91: Canfigure
Screen

ID-FIELD FRAMETTFE ; Sl ERROR
1 1 uc 1004 EE 0.00s @ -
23 &3 uc 12 34 AB CD 40 21.736ms
12 az uc 1122 Co 180 34ms
1 1 uc 1004 EE 200 83ms
23 23 uc 12 24 AR CD 40 270.10ms
a0 FO uc 12 34 AB CD 75 64 64 76 eC 282 78ms
1 1 uc 1001 EE 403 11ms
12 az uc 1122 oo 452 36ms
23 &3 uc 12 34 AR CD 40 £20.32ms
a0 FO uc 12 24 AR CD 75 64 64 76 ac 523446 ms

Fi gure 4-51: Results of LIN protocol
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Results for CAN and LI N Protocols
Results > Details

Once the protocol is decoded, the results are automatically displayed.
However, you can also select Results > Details and click Protocol Listing to
view the results.

Figure 4-52 shows the results of CAN and LIN protocol decoding.
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Figure 4-52: Results of CAN and LIN protocols
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Results for Eye Di agram
Results > Details

The result for the CAN Eye Diagram test is an Eye diagram plot. Click the
View Eye Diagram button to view a plot of the eye diagram.

Figure 4-53 shows the Eye Diagram with Ack bit information.

Cursor Readouts

14.6us
45.3us
30.fus
J2Emy
§34mvr

-94.9m=

=
=
—_
=
=
-
-
i~

Clock Recovery

ﬂ Include Ack

violtage

=

=  Time [6.00us/Sdiv]
d creen

Figure 4-53: Eye diagramwith Ack bit information
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Figure 4-54 shows the Eye Diagram without Ack bit information.

CANM Data Eve Diagram

e Rese
+ —
T : Cursor Readouts
CAN Data Eye Diagram Y 5?49?' r:if
' X1 15.4us

X2 45.3us
AX 30.2us
hi TaFmy
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AY 34.9m=

=
=
—
=
E
-
[
(o}

Clock Recovery

. Include Ach

Yaltage

-

: = Time [6.00us/ div]
=] creen

Figure 4-54: Eye diagramwi thout Ack bit information
Use the toolbar to:
B Save the Eye Diagram as a .jpg file
®  Zoom the Eye diagram
®  Reset the Eye diagram to its original display
®  View the cursor readouts

Click the Half Screen button to view the Eye Diagram display in half screen
mode.
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Eye Di agram Pl ot
Results > Details

Click the View Eye Diagram button to view a plot of the eye diagram. The
Eye diagram is displayed in the lower half of the oscilloscope screen. To
view the eye diagram plot in full screen mode, click the Full Screen button.
When in the full screen mode, this button changes to Half Screen.

The Eye diagram plot has a toolbar that you can use to Save the Plot, Zoom
In or Zoom Out, Reset Plot, and Display the cursors.

Table 4-26 lists the toolbar options and their descriptions.

Tabl e 4-26: Tool bar options and their actions

Toolbar buttons/Option Action

Saves the eye diagram plot as a .jpg image

Zooms in the eye diagram plot
I:-Bﬁ Y gramp
Zooms out the eye diagram plot
=)
)
Reset Resets the eye diagram plot to the original state
Flot

Places Cursor1 at the point you click and displays the X, Y values in readouts

values in readouts

I 'T\.Ile Places Cursor2 at the point you click and displays the X, Y, Delta X, and Delta Y,

Clock Recovery Includes or excludes the Ack bit for clock recovery.

ﬂ Include Achk
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Results for Oscillator Tol erance
Results > Details

The results for the Oscillator Tolerance test give the Maximum, Minimum,
and Average tolerance values with and without the Ack bit used for Clock
Recovery. The Oscillator Tolerance is in %.

Figure 4-55 shows the results of the Oscillator Tolerance test.

File Tests Results Utilities Help TDSWNM m| x|
Oscillator Tolerance Measurement

Select 1: 21

Without Ack With Ack i :
Configure - i . T =

A T 3 ax: 025178 aH: s ] I
rigger : e Clear
Setup q: : q: 0.25 Il |

Run Mode
Connect Single "

Oscillatar Tolerance | Bus: Che; CAN-DA-HL; 10kbps | 1D: 24 Ready

Figure 4-55: Results for oscillator tolerance
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Results for Data Rate
Results > Details

The results for the Data Rate test give the Maximum, Minimum, and Average
measurement with and without the Ack bit used for clock recovery. The Data
Rate is in Kbps.

Figure 4-56 shows the results of the Data Rate test.

File Tests Results Utilities Help TDSVYHM m x|
Data Rate Measurement

Selact =12 3

Without Ack With Ack

. Configure . i 7 R Min: 1

— | ax: 10.027kbps Max: 1001 |
rigger
Setup g: : Aug: 10.025kbps

Run Mode

Conneact

[rata Rate | Bus: Bef2; CAN-DW-HL,; 10kbps | ID: 123 Reaady

Figure 4-56: Results for data rate
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Results for Bus Traffic
Results > Details
The results for the Bus Traffic test are as follows:

®  The Load tab gives bus load occupancy (in percentage) and a
corresponding Bus Occupancy pie chart. You can also input an ID value
and press Enter to update the pie chart for that ID.

Figure 4-57 and Figure 4-58 show the results of the Bus Traffic test.

File Tests Results Utilities Help TDSVNM m| x|

Bus Traffic Measurement
Bus Occupancy Pie Chart

Select | Load " Frame Count

B Other I0=
Configure L W Sclocted ID

M [dle

Trigger
Setup |

Connect

Bus Traffic | Bus: Ref1; CAN-DW-HL; 2Zkbps Ready

Figure 4-57: Results for bus traffic (Load tab)

®  The Frame Count tab displays the Data, Remote, Error, Overload, and
the total number of frames.

File Tests Results Utilities Help TDSVNM || x|

Bus Traffic Measurement

Select | Load (% " Frame Count Bue Occupancy Pie Chart

Data:

Configure
£ Remote:

Error: 0 Hidle

Trigger
Setup | Ouverload:

Total:

Connect

Bus Traffic | Bus: Ref1; CAN-DW-HL; 33kbps Ready

Figure 4-58: Results for bus traffic (Franme Count tab)
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Results for Wakeup Tine
Results > Details

If you are using a differential probe, upon clicking Run the application
displays the following message—Turn on the ignition to trigger the
oscilloscope.

When you switch on the battery power supply (equivalent to turning on an
engine), the test executes and displays the Wakeup Time and Active Frame
Time values (in seconds).

If you are using a single-ended probe, upon clicking Run the application
displays the following message—Do the vertical setting on the oscilloscope.
Press OK when vertical setting is done.

Upon clicking OK the application displays the following message—Turn on
the ignition to trigger the oscilloscope. The test executes and displays the
Wakeup Time and Active Frame Time values (in seconds).

Figure 4-59 shows the results of the Wakeup Time test.

File Tests Results Utilities Help TDSYNM m| x|

Salact

Configure

Trigger |
. Setup |

Conneact

Wakeup Time Measurement

Wakeup Time: 200ms

Active Frame Time: 207 ms

Wiakeup Time | Bus: Ref?; CAN-DW-LH; S0kbps | Settling Latency Time: 190ms Ready

Fi gure 4-59: Results for wakeup tine
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Results for Propagation Del ay
Results > Details

For the Propagation Delay test, the window displays the Propagation Delay
value in nanoseconds.

Figure 4-60 shows the results of the Propagation Delay test.

File Tests Results Utilites Help TDSYNM m| x|

Propagation Delay Measurement

Configure

Propagation Delay: 57.1ns

Trigger |
Setup

Conneact

FPropagation Delay | Bus: From Refl To Ref2; CAN-DWU-HL; 10kbps Ready

Figure 4-60: Results for propagation del ay

96 TDSVNM Timing and Protocol Decode Software



How to ...

Install ATM 1 License

ATM 1 License Installation
Utilities > ATM-1 License Installation

Use this option if the license key is not installed.

Note: Contact Crescent Heart Software (www.c-h-s.com) for more
information on the license key.

To install or upgrade the license key information for the ATM-1 automotive
trigger module, perform the following steps:

1. Click Utilities > ATM-1 License Installation.

2. Enter the license key that you received with the ATM-1 trigger module
in the dialog box that opens and click OK.
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Shortcut Keys

Tabl e 5-1: Shortcut keys

Menu/Menu items Shortcut key
File Alt+F

File > Recall Default Alt+F+D
File > Recall Alt+F+R
File > Save At+F+S
File > Recall Recent Alt+F+E
File > Recall Recent > First Recent At+F+E+1
File > Recall Recent > Second Recent Alt+F+E+2
File > Recall Recent > Third Recent Alt+F+E+3
File > Recall Recent > Fourth Recent At+F+E+4
File > Preferences Alt+F+P
File > Minimize Alt+F+M
File > Exit Alt+F+X
Tests Alt+T

Tests > Select Alt+T+S
Tests > Configure Alt+T+C
Tests > Trigger Setup At+T+T
Tests > Connect Alt+T+N
Results Alt+R
Results > Details Alt+R+D
Utilities Alt+U
Utilities > ATM-1 License Installation Alt+ U+A
Help Alt+H

Help > Help Topics At+H+T
Help > About TDSVNM Alt+H+A
Help > About ATM-1 Alt+H+M
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Error

Messages

Tabl e 5-2: Error nessages

Error Error message Description Possible solution

code

110 Unable to trigger and acquire the The oscilloscope is not able to Configure the correct trigger source,
waveform. Press F1 for more details. acquire the signal because the and rerun the measurement.

trigger is not available.

111 Failed to import the waveform. Press The import of the waveform from Reacquire the new waveform.

F1 for more details. the acquisition memory has
failed because there is no valid
waveform.

112 Invalid waveform record length. Press This message appears Acquire the waveform with record
F1 for more details whenever the waveform record length is less than 16 M and rerun

length is greater than 16 M. the selected test.

200 Conflict in selecting sources. Sources The sources selected for Bus1 Select different input sources for
for Bus1 and Bus2 are same. Press and Bus2 are the same. Bus1 and Bus2.

F1 for more details.

201 Conflict in selecting sources. Sources The sources selected for Bus1 Select different input sources for
for Bus1 and CAN Node sensor are and CAN Node sensor are the Bus1 and CAN Node sensor.
same. Press F1 for more details. same.

202 Conflict in selecting sources. Bus2 The sources selected for Bus2 Select different channel sources for
and CAN Node senor are same. Press | and CAN Node sensor are the Bus2 and CAN Node sensor.

F1 for more details. same.

203 Conflict in selecting sources. Bus1 The math destinations selected Select different Math destinations
Math and Bus2 Math are same. Press | for Bus1 and Bus2 are the same. | for Bus1 and Bus2.

F1 for more details.

204 Conflict in selecting sources. Bus1 The math destination selected Select different Math destinations
Math and CAN Node senor Math are for Bus1 and CAN Node sensor for Bus1 and CAN Node sensor.
same. Press F1 for more details. are the same.

205 Conflict in selecting sources. Bus2 The math destination selected Select different Math destinations
Math and CAN Node senor Math are for Bus2 and CAN Node sensor for Bus2 and CAN Node sensor.
same. Press F1 for more details. are the same.

207 Conflict in selecting sources. Sources Selected sources are using Live Select the sources such that all the
cannot be Live and Ref. Press F1 for and Ref channels sources are Live or Ref.
more details. simultaneously.

208 Unable to decode. Source waveforms The Bus1 and Bus2 waveforms Acquire the Bus1 and Bus?2
have different time/div settings. Press have different time/div settings. waveforms on the same Trigger,
F1 for more details. save to the Ref waveforms and

rerun the selected test.

209 Unable to decode. Source waveforms The Bus1 and Bus2 waveforms Acquire the Bus1 and Bus?2
have different record lengths. Press have different record lengths. waveforms on the same Trigger,
F1 for more details. save to the Ref waveforms and

rerun the selected test.
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Tabl e 5-2: Error

nessages (cont.)

Error Error message Description Possible solution
code
211 Conflict in selection of sources. Check | One of the following conflicts has | Select a different source for Stuff
if: occurred: waveform destination.
1. Bus Source and Stuff waveform 1. Bus Source and Stuff
destination are the same. waveform destination are
2. CAN Node sensor source and the same.
Stuff waveform destination are 2. CAN Node sensor source
the same. and Stuff waveform
Press F1 for more details. destination are the same.
401 Unable to locate edges on the The application is unable to Enter the Ref Level value where the
waveform. Check if: locate the edges on the transition occurs on the waveform.
1. The probe is connected waveform at the transition Enter 50% as Ref level and 20% as
correctly (for channel sources). because the voltage level does Hysteresis in File > Preferences.
2 The reference levels entered not fall in the transition range of
are correct. the waveform.
Press F1 for more details.
402 Unable to decode the signal. Ensure The application is unable to Enter the correct data rate, CAN
that: decode the signal. This error type and ensure that at least one
1. The bus is operating at the set occurs when: complete frame is present in the
data rate. 1. Anincorrect data rate is signal. Rerun the test.
2. The bus type is correct. entered.
3. One complete frame is 2. Anincorrect CAN type is
available. entered.
Press F1 for more details. 3. Anincomplete frame is
present.
403 The frames in this signal are invalid. The application is unable to Enter correct data rate, CAN type
Ensure that: decode the signal. This error and ensure that at least one
1. The bus is operating at the set occurs when complete frame is present in the
data rate. 1. Anincorrect data rate is signal. Enter the correct reference
2. The probe is connected entered. level and hysteresis for the signal.
properly (for channel sources). 2. Anincorrect CAN type is Rerun the test.
3. The reference levels entered entered.
are correct. 3. Anincomplete frame is
Press F1 for more details. present.
4. Reflevels are incorrect.
5. There are spikes on the
signal.
501 Unable to calculate the Bus Traffic. Unable to decode the Frame Select the correct data rate. Rerun
Check if the bus is operating at the set | correctly. The number of bits is the test.
data rate. Press F1 for more details. high because a wrong data rate
is entered.
510 The specified ID cannot be found in The decoded CAN frames do not | Decode the bus to determine the ID.

the signal. Check if the ID is present
on the bus. Press F1 for more details.

have the specified ID.

Enter the same ID. Rerun the test.
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Tabl e 5-2: Error

nessages (cont.)

Error Error message Description Possible solution

code

520 Unable to detect an Active Error This error occurs when the first Ensure that:
frame. Improper wakeup signal. Press | frame is not a good frame or a The CAN message occurs after the
F1 for more details. frame with an active error. Wakeup signal.

The levels for the wakeup detection
are correct.
The Latency time is correct.

521 Unable to detect a good frame. The application is unable to Ensure that the other CAN node
Improper wakeup signal. Press F1 for detect a good frame. This error comes up and send an ACK so that
more details. occurs when the first message is | a good frame is available.

an active error frame and all
subsequent frames are error
frames.

522 This is not a proper wakeup signal. Measured wakeup time is Apply proper wakeup signal and
Wakeup time cannot be negative. negative. rerun the measurement again.
Press F1 for more details.

530 The slopes of the From source signal From source signal and To Connect From source and To
and the To source signal do not signal slopes do not match. This source to either CAN-DW-HL or
match. Check the polarity of the error occurs when one of the CAN-DW-LH and rerun the
probes. Press F1 for more details. sources is connected to CAN- measurement.

DW-HL and other is connected
to CAN-DW-LH.

603 Cursor position is out of range. Press Cursor position is beyond the Rerun the test.

F1 for more details. waveform’s horizontal range
on the oscilloscope.

605 Waveform not available on the source. | Cannot link the selected Rerun the test.

Press F1 for more details. message to the waveform. The
waveform on the selected
source does not match the
decoded waveform.

701 Cannot find the frames specified by The specified Search/Filter Enter a valid Search/Filter condition.
the Search/Filter condition. condition is not valid or no

frames match the search
condition.

702 The CAN node sensor ID and the The CAN node sensor ID and Select a row with the specified CAN
selected frame ID do not match. selected ID in the protocol node sensor ID.

analysis window are different.

801 Unable to communicate with the The application is not able to Check the USB connections and try
ATM-1 trigger module. communicate with the ATM-1 running the measurement again.

trigger module.

802 The ATM-1 trigger module license key | The license key entered is Enter a valid license key.
is invalid. Press F1 for more details. invalid.

102 TDSVNM Timing and Protocol Decode Software



References

Default Settings Part |

Tabl e 5-3: Default application settings

Menu/Parameter Selections Default

File > Preferences

Math Destination (for single-ended probes)

Bus1 Source Math1, Math2, Math3, Math4 Math1

Bus2 Source Math1, Math2, Math3, Math4 Math2

CAN Node Sensor Source Math1, Math2, Math3, Math4 Math3

Reference Level

Bus1 Source

Units Perc(%), Abs Perc(%)

Mid 20 - 80% 50%

Hysteresis 5-40% 20%

Bus2 Source

Units Perc(%), Abs Perc(%)

Mid 20-80% 50%

Hysteresis 5-40% 20%

CAN Node Source

Slope Rise, Fall Rise

Units Perc(%), Abs Perc(%)

Mid 20-80% 50%

Hysteresis 5-40% 20%

Do Autoset Every Time Unchecked

Tests > Select

Protocol Decoding CAN, LIN, CAN & LIN CAN

Timing Analysis Tests Oscillator Tolerance, Eye Diagram, Data Rate, Bus None

Traffic, Wakeup Time, Propagation Delay

Tests > Configure

CAN

Trigger Using DPO-CAN, ATM-1, Standard DPO-CAN (for a DPO
oscilloscope and when CB:
CAN Bus Trigger option is
enabled); else ATM-1

Probe Type Differential, Single-ended Differential

Bus1 Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4 Ch1

Bus1 Type CAN-DW-HL, CAN-DW-LH, CAN-SW, CAN-Fault-T-HL, CAN-DW-HL

CAN-Fault-T-LH

Bit Rate 10 Kbps — 1 Mbps 10 Kbps

Bus2 Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4, None None

Bus2 Type CAN-DW-HL, CAN-DW-LH, CAN-SW, CAN-Fault-T-HL, None

CAN-Fault-T-LH, None

Table 5-3: Default application settings(cont.)
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Menu/Parameter Selections Default

Bit Rate 10 Kbps — 1 Mbps 10 Kbps

CAN Node Sensor Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4, None None

Analysis Data, Timing Data

LIN

Probe Type Differential, Single-ended Differential

Bus1 Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4 Ch1

Bus1 Type LIN LIN

Bit Rate 1 Kbps — 20 Kbps 10 Kbps

Bus2 Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4, None None

Bus2 Type LIN, None None

Bit Rate 1 Kbps - 20 Kbps 10 Kbps

Analysis Data, Timing Data

CAN & LIN

Trigger Using DPO-CAN, ATM-1, Standard DPO-CAN (for a DPO
oscilloscope and when CB:
CAN Bus Trigger option is
enabled); else ATM-1

Probe Type Differential, Single-ended Differential

Bus1 Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4 Ch1

Bus1 Type CAN-DW-HL, CAN-DW-LH, CAN-SW, CAN-Fault-T-HL, CAN-DW-HL

CAN-Fault-T-LH

Bit Rate 10 Kbps — 1 Mbps 10 Kbps

Bus2 Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4 Ch2

Bus2 Type LIN LIN

Bit Rate 1 Kbps - 20 Kbps 10 Kbps

CAN Node Sensor Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4, None None

Analysis Data, Timing Data

Tests > Trigger Setup

CAN (When Trigger Using is set to ATM-1)

Trigger-In Source Aux In, Ch1, Ch2, Ch3, Ch4 Aux In

Sample Point Location 20% —90% 60%

Trigger Event Select Elementary, Logical, Advanced Elementary

ACK No, Yes No

CAN & LIN

Trigger-In Source Aux In, Ch1, Ch2, Ch3, Ch4 Aux In

Sample Point Location 20% - 90% 60%

Trigger Event Select Elementary, Logical, Advanced Elementary

ACK No, Yes No

Table 5-3: Default application settings(cont.)

Menu/Parameter Selections Default
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Tests > Trigger Setup
CAN (When Trigger Using is set to DPO-CAN)
Trigger On CAN Message, Frame ID, DATA, ID and DATA, EOF, ID and DATA
Missing ACK
CAN Type Standard, Extended Standard
Format Hex, Binary Hex
Data Direction Either, Data Frame, Remote Frame Either
ID XXX
Data XX XX XX XX XX XX XX XX
CAN & LIN
Trigger On CAN Message, Frame ID, DATA, ID and DATA, EOF, ID and DATA
Missing ACK
CAN Type Standard, Extended Standard
Format Hex, Binary Hex
Data Direction Either, Data Frame, Remote Frame Either
ID XXX
Data XX XX XX XX XX XX XX XX
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Default Settings Part |1

Tabl e 5-4: Default application settings

Menu/Parameter

Selections

Default

Tests > Configure

Oscillator Tolerance, Eye Diagram, Bus Traffic, Data Rate, Wakeup Time

Trigger Using DPO-CAN, ATM-1 DPO-CAN (for a DPO
oscilloscope and when CB:
CAN Bus Trigger option is
enabled); else ATM-1
Probe Type Differential, Single-ended Differential
Bus Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4 Ch1
Bus Type CAN-DW-HL, CAN-DW-LH, CAN-SW, CAN-Fault-T-HL, CAN- CAN-DW-HL
Fault-T-LH
Bit Rate 10 Kbps — 1 Mbps 10 Kbps
Propagation Delay
Probe Type Differential, Single-ended Differential
From Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Refd Ch1
To Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4 Ch2
Bus Type CAN-DW-HL, CAN-DW-LH, CAN-SW, CAN-Fault-T-HL, CAN- CAN-DW-HL
Fault-T-LH
Bit Rate 10 Kbps — 1 Mbps 10 Kbps
Tests > Trigger Setup
Oscillator Tolerance, Eye Diagram, Data Rate
Trigger-In Source Aux In, Ch1, Ch2, Ch3, Ch4 Aux In
Sample Point Location 20% - 90% 60%
Input ID XXXXX XXXXX
ACK No, Yes No
Bus Traffic
Trigger-In Source Aux In, Ch1, Ch2, Ch3, Ch4 Aux In
Sample Point Location 20% - 90% 60%
Trigger Event Select Elementary Elementary
ACK No, Yes No
Wakeup Time
Trigger-In Source Aux In, Ch1, Ch2, Ch3, Ch4 Aux In
Settling Latency Time 190 ms — 240 ms 190 ms
Trigger Slope Rise, Fall Rise
Trigger Level —40V-+40V 12V
Elementary Trigger Settings
Trigger On CAN message, ID, Data, ID and Data, Data Frame, Remote Data Frame
Frame, Error Frame, Overload Frame
CAN Type Standard, Extended Standard
Error Type Active, Passive, CRC, Any, Form, ACK Active
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Tabl e 5-4: Default application settings (cont.)

Menu/Parameter Selections Default
Format Binary, Hex Hex
ID =, 1=,<,<=,>,>= Isin, Is not in =
DLC XXXXX
Data =, 1=, <<=, > >=Isin, Is notin =
Logical Trigger Settings
Format Binary, Hex Hex
Trigger On ID, Id and Data, Data Frame, Remote Frame, Overload Frame Data Frame
ID =, 1=, <, <=, > >=, Isin, Is notin =
DLC XXXXX
Data =, 1=, <, <=, > >= Isin, Isnotin =
Advanced Trigger Settings
Format Binary, Hex Hex
Trigger Sequence #1, #2, #3
Trigger On ID, Id and Data, Data Frame, Remote Frame, Overload Frame Data Frame
DLC XXXXX
ID =, 1=, <, <=, >, >= Isin, Is notin =
Data =, |=, <, <= > >= [sin, Is not in =
Action #1 Trigger-out, Start Timer #1, Start Timer #2, Stop Timer #1, Stop Trigger-out
Timer #2, Reset Counter #1, Reset Counter #2, Inc Counter
#1, Inc Counter #2, Dec Counter #1,
Dec Counter #2, Go To Seq #1, Go To Seq #2,
Go To Seq #3
Action #2 Trigger-out, Start Timer #1, Start Timer #2, Stop Timer #1, Stop None
Timer #2, Reset Counter #1, Reset Counter #2,
Inc Counter #1, Inc Counter #2, Dec Counter #1,
Dec Counter #2, Go To Seq #1, Go To Seq #2,
Go To Seq #3, None
Action #3 Trigger-out, Start Timer #1, Start Timer #2, Stop Timer #1, Stop None
Timer #2, Reset Counter #1, Reset Counter #2, Inc Counter
#1, Inc Counter #2, Dec Counter #1,
Dec Counter #2, Go To Seq #1, Go To Seq #2,
Go To Seq #3, None
Results
Stuff Destination NA Ref1
Save/Recall File (.CSV) NA C:\TekApplications\TDSVNM\

Reports\Decode.csv
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Measur enent Al gorithns

Triggered wavaform

:

Extract crossings

.

Conver to bit stream

!

Detect SOF

:

Find erraors

:

Detect EQOF

}

Decode protocol

messages betweaen
SOF and EOF

!

l[dentify errar type

CAN Pr ot ocol

The CAN protocol can be standard or extended message. When the
configured trigger condition occurs and the waveform has been acquired, the
application performs the following steps:

1.
2.

Extracts crossings on the waveform, based on the configured Ref Levels.

Converts the waveform into a stream of bits using the nominal bit rate
that you entered.

Analyzes the bit stream to detect CAN frames; it identifies the SOF,
looks for error frames and based on this, detects the EOF.

Once complete frames have been identified on the converted bit stream,
decodes the Bit stream framewise, excluding the stuff bits.

Figure 5-1 shows the steps in decoding a CAN protocol.

Figure 5-1: Steps in CAN protocol decoding
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Triggered wavefarm

!

Extract crossings

|

Convert to hit stream

I

Detect SOF

!

Decode data

'

Decaode frame type

!

Find errors and errar
types

LI N Protocol

Once the waveform is acquired on the edge trigger, the application performs
the following steps:

1.

2.

4.

5.

Extracts crossings on the waveform based on the configured Ref Levels.

Converts the waveform into a stream of bits using the nominal bit rate
entered by the user.

Analyzes the bit stream to detect LIN frames; after identifying the SOF,
decodes the Bit stream framewise.

Detects the LIN frame type.

Detects LIN errors and error types.

Figure 5-2 shows the steps in decoding a LIN protocol.

Figure 5-2: Steps in LIN protocol decoding
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GCscill ator Tol erance

The Oscillator tolerance range test measures the deviation of the measured
data rate from actual data rate. This data rate deviation is a result of the
tolerance deviation of the oscillator.

The results give the tolerance values with and without Ack bit used for clock
recovery. This gives the tolerance value that the selected node should have to
decode the incoming data correctly. The tolerance range should be good
enough so that node can transmit data and receive data correctly and
participate in the arbitration without affecting the other node.

Oscillator tolerance is used to check for the following cases:
Case 1

If stuff violations occur, the receiver node should be able to decode the 11th
bit as a stuff violation. In this condition, resynchronization happens only after
the 10th bit interval. The oscillator tolerance is:

M < 10 *?w 246
nbi
where,
Tsjw 1s the resynchronization jump width
Ty 1s nominal bit time

Af is the frequency tolerance

The nominal bit time is given by:

Tope = %BR

where BR is the nominal bit rate. It is the number of bits per second
transmitted by an ideal transmitter in the absence of resynchronization and is
determined by the nominal bit rate specified by the user.

Case 2

When there is an error frame and it is an active error, there can be 12 bits
without resynchronization. The oscillator tolerance is such that the 13th bit
can be detected. Here, the oscillator tolerance is:

. { Phase  Segl, Phass Seg2)min

A
2*(13*7T,, — FPhase _ segl)
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These two cases deal with the accumulated phase error at different
conditions.

The CAN System clock (Tq) is derived from the oscillator and is divided by
the bit rate preschooler. The value of Tq depends upon the number of quantas
programmed for the nodes. So the bit rate variation directly reflects the
variation of Tq and subsequently the clock of the crystal.

Algorithm for this measurement: Recover the clock on the selected Id
CAN frame. Calculate the recovered clock period and its deviation from the
programmed data rate.

In this example, the recovered clock period is the actual period Tactual.

_ F’acﬁuaf — T}z-::-mm.:zﬂ 3

o0

Tactual

The tolerance is derived from actual data rates. The clocks are recovered
using the edge crossing of the resynchronization edges.

Eye Di agram

The Eye Diagram measurement plots the CAN bits one after the other. This
plot shows the transition of each bit in the CAN message and enables you to
choose a suitable sampling point for the CAN node.

The cursor feature on the plot enables you to measure the voltage levels and
the crossover time of the transition bit. The ACK and NO ACK features help
to measure the deviation of this bit from the regular transmitted bits.

The individual bits are separated from the CAN message bit stream for the
selected ID. The separation is based on the recovered clock interval. The
clock recovery mechanism uses the resynchronization transition so that the
eye diagram gives a pictorial view of the bits seen on the ECU that is
connected on the network.

Optimum samples should be present to draw the eye diagram. The trigger
module will trigger and capture the particular frame id. Each captured event
is stored in the Fast Frame segments or frames, concatenated, and displayed
in the order they were captured. This feature essentially allows you to remove
unwanted sections of the waveform so you can focus on the signal of interest.

Dat a Rate

The Data Rate test measures the data rate of the selected ID. The data rate
measurement enables you to measure the actual data rate of the CAN bus
signal transmitted by the node of the selected ID. The data rate is measured
with the clock recovery technique which uses the resynchronization edge
time.
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The results give the data rate values with and without Ack bit (from the other
node) used for clock recovery. The deviation measurement enable you to
program your node for the correct data rate.

The application measures the nominal data rate derived from the data
transition of the selected ID. If there are more frames of the same ID in the
acquisition, it also calculates the maximum, minimum, and average data
rates.

The data rate is calculated using the technique illustrated in the oscillator
tolerance section of this document.

Bus Traffic

Measures the bus traffic on the CAN network enabling you to determine the
traffic load on the bus. This also enables you to estimate the T bus
availability to transmit messages by lower priority nodes by finding the node
that occupies the maximum time on the bus.

If each message time is B(i) and N is the number of messages in the
acquisition record, message occupancy time is:

Toceupy = Z:V B(5)

Within the acquisition record, the complete CAN message starts from the
time Tstart of the first message and the end of the last message at Tend. The
duration of the traffic considered for the measurement is:

Td = TEna‘ - Tﬁ’mn
Blogd = Taccupy

Measuring the occupancy of any given ID: A novel way of identifying and
representing bus that has been occupied by the particular ID can be calculated
as follows.

1. Decode the CAN message from the acquired waveform on the
oscilloscope.

2. Calculate each message time from the start of the frame to the end of the
frame and decode each message.

3. Assign the message time for each message to T(n) where n varies from 0
to N for N+1 messages.

4. In the decoded message, assume that there are k different IDs, and each
ID may be repeated a maximum of z times.

5. The CAN message from the node k that has occupied the bus time is
Tkoccupy.

TDSVNM Timing and Protocol Decode Software



References

Thocoupy = Z:l:. Tix)
The bus load due to the message from the particular node is given by:

Tload = Thoccupy

This Tkload will be represented in a PIE chart as a percentage of occupancy
on the full bus load (Bload).

Wakeup Ti ne

Wakeup Time is the time measured from the ignition signal to the first frame
transmitted on the bus. This test measures the time taken by the CAN bus
network to become active on the network from the time the ignition is
switched on. The first message transmitted may not acknowledged by the
other node. But when two or more nodes come up on the network, the
message is acknowledged. The time measured from the ignition to the time
that the first active message is acknowledged is known as active time.

In general, wakeup time can be in the range from 190 ms to 240 ms.

Propagati on Del ay

Propagation Delay is the time taken by the CAN message to travel from a
transmitter at one end of the bus to a receiver at the other end of the bus.

The oscilloscope is set to trigger on the start of the frame (SOF) of a CAN
message set as the 'From Source'. Once an SOF occurs, the waveform is
captured and the application extracts the edges based on the configured Mid
level and Hysteresis. The acquired waveform looks like the waveform in the
following figure. The time difference (At) between the SOF of 'To Source'
and 'From Source' is measured. This time difference gives the propagation
delay.
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If the 'From Source' and the '"To Source' are reversed, propagation delay is
negative.

From Source Wim \

T
‘L —|_ Ilid Level

™

To Source wim

AT - Propagation Delay

Figure 5-3: Exanple of propagation del ay

Note: The propagation delay multiplied by two gives the loop delay of the
network.
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